aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..a615408
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,27 @@
1{
2 description = "A very basic flake";
3
4 outputs = { self, nixpkgs }:
5 let
6 supportedSystems = [ "x86_64-linux" ];
7 forAllSystems = nixpkgs.lib.genAttrs supportedSystems;
8 nixpkgsFor = forAllSystems (system: import nixpkgs { inherit system; });
9 in
10 {
11
12 devShell = forAllSystems (system:
13 let
14 pkgs = nixpkgsFor."${system}";
15 in
16 pkgs.mkShell {
17 nativeBuildInputs = [
18 pkgs.rustc
19 pkgs.cargo
20 pkgs.rust-analyzer
21 pkgs.cargo-watch
22 ];
23 RUST_BACKTRACE = 1;
24 }
25 );
26 };
27}