aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix14
1 files changed, 5 insertions, 9 deletions
diff --git a/shell.nix b/shell.nix
index c0e1bb0..1ad58f4 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,10 +1,6 @@
1{ pkgs ? import <nixpkgs> {} }: 1# The `default.nix` in flake-compat reads `flake.nix` and `flake.lock` from `src` and
2# returns an attribute set of the shape `{ defaultNix, shellNix }`
2 3
3pkgs.mkShell { 4(import (fetchTarball "https://github.com/edolstra/flake-compat/archive/master.tar.gz") {
4 buildInputs = with pkgs; [ 5 src = ./.;
5 cargo 6}).shellNix
6 rustc
7 rustfmt
8 pkg-config
9 ];
10}