aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index 3f416a9..f57d49b 100644
--- a/flake.nix
+++ b/flake.nix
@@ -47,7 +47,7 @@
47 prompt = with final; 47 prompt = with final;
48 let 48 let
49 pname = "prompt"; 49 pname = "prompt";
50 packageMeta = (lib.importTOML ./bin/Cargo.toml).package; 50 packageMeta = (lib.importTOML ./Cargo.toml).package;
51 rustPlatform = makeRustPlatform { 51 rustPlatform = makeRustPlatform {
52 inherit (rustChannel final) cargo rustc; 52 inherit (rustChannel final) cargo rustc;
53 }; 53 };
@@ -56,10 +56,10 @@
56 inherit pname; 56 inherit pname;
57 inherit (packageMeta) version; 57 inherit (packageMeta) version;
58 58
59 buildInputs = [ 59 nativeBuildInputs = [ pkgconfig ];
60 final.openssl 60 buildInputs = [ openssl ];
61 final.pkgconfig 61
62 ]; 62 doCheck = false;
63 63
64 src = gitignoreSource ./.; 64 src = gitignoreSource ./.;
65 cargoLock.lockFile = ./Cargo.lock; 65 cargoLock.lockFile = ./Cargo.lock;