aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 3 insertions, 9 deletions
diff --git a/flake.nix b/flake.nix
index f57d49b..eb32a4e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -8,22 +8,14 @@
8 inputs.nixpkgs.follows = "nixpkgs"; 8 inputs.nixpkgs.follows = "nixpkgs";
9 }; 9 };
10 10
11 gitignore = {
12 url = "github:hercules-ci/gitignore.nix";
13 inputs.nixpkgs.follows = "nixpkgs";
14 };
15
16 }; 11 };
17 12
18 outputs = 13 outputs =
19 { self 14 { self
20 , nixpkgs 15 , nixpkgs
21 , fenix 16 , fenix
22 , gitignore
23 }: 17 }:
24 let 18 let
25 inherit (gitignore.lib) gitignoreSource;
26
27 supportedSystems = [ "x86_64-linux" "aarch64-linux" "x86_64-darwin" "aarch64-darwin" ]; 19 supportedSystems = [ "x86_64-linux" "aarch64-linux" "x86_64-darwin" "aarch64-darwin" ];
28 forAllSystems = nixpkgs.lib.genAttrs supportedSystems; 20 forAllSystems = nixpkgs.lib.genAttrs supportedSystems;
29 nixpkgsFor = forAllSystems (system: 21 nixpkgsFor = forAllSystems (system:
@@ -61,7 +53,7 @@
61 53
62 doCheck = false; 54 doCheck = false;
63 55
64 src = gitignoreSource ./.; 56 src = self;
65 cargoLock.lockFile = ./Cargo.lock; 57 cargoLock.lockFile = ./Cargo.lock;
66 }; 58 };
67 59
@@ -89,6 +81,8 @@
89 in 81 in
90 pkgs.mkShell { 82 pkgs.mkShell {
91 nativeBuildInputs = [ 83 nativeBuildInputs = [
84 pkgs.pkgconfig
85 pkgs.openssl
92 pkgs.bacon 86 pkgs.bacon
93 rust-analyzer 87 rust-analyzer
94 toolchain 88 toolchain