aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAkshay <[email protected]>2021-09-26 16:56:36 +0100
committerAkshay <[email protected]>2021-09-26 16:56:36 +0100
commit5cdb4e421a809de51c3ebe8404e50d732721238b (patch)
tree73b71617c41b3e13edbf26035e821bb884d30441 /flake.nix
init
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix52
1 files changed, 52 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..330ca03
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,52 @@
1{
2 description = "nerdypepper's nixos config";
3
4 inputs = {
5 nixpkgs.url = "github:NixOS/nixpkgs/nixos-21.05";
6 nixos-hardware.url = "github:nixos/nixos-hardware";
7 home-manager = {
8 url = "github:nix-community/home-manager/release-21.05";
9 inputs.nixpkgs.follows = "nixpkgs";
10 };
11 neovim.url = "github:nix-community/neovim-nightly-overlay";
12 };
13
14 outputs =
15 { self
16 , nixpkgs
17 , nixos-hardware
18 , home-manager
19 , neovim
20 , ...
21 } @ inputs: {
22
23 overlays = {
24 nvim-nightly = neovim.overlay;
25 };
26
27 nixosConfigurations = {
28 olive = nixpkgs.lib.nixosSystem {
29 system = "x86_64-linux";
30 modules = [
31 {
32 imports = [ ./hosts/olive/configuration.nix ];
33 _module.args.self = self;
34 }
35 home-manager.nixosModules.home-manager
36 {
37 home-manager.useGlobalPkgs = true;
38 home-manager.useUserPackages = true;
39 home-manager.users.np = {
40 imports = [ ./home.nix ];
41 _module.args.self = self;
42 _module.args.inputs = inputs;
43 _module.args.theme = import ./theme.nix;
44 };
45 }
46 ];
47 };
48 };
49
50 };
51
52}