aboutsummaryrefslogtreecommitdiff
path: root/hosts/laurel/servarr.nix
diff options
context:
space:
mode:
authorAkshay <[email protected]>2024-05-05 09:08:34 +0100
committerAkshay <[email protected]>2024-05-05 09:10:55 +0100
commit043062eac50e86623044f889031f40f0d6d3c081 (patch)
tree466f02e4fa2ddcb15d97919b857b64598b42935d /hosts/laurel/servarr.nix
parentb62fffe23785c146193d69f1718a953e108e6da2 (diff)
move servarr to laurel
Diffstat (limited to 'hosts/laurel/servarr.nix')
-rw-r--r--hosts/laurel/servarr.nix87
1 files changed, 87 insertions, 0 deletions
diff --git a/hosts/laurel/servarr.nix b/hosts/laurel/servarr.nix
new file mode 100644
index 0000000..8b5dd83
--- /dev/null
+++ b/hosts/laurel/servarr.nix
@@ -0,0 +1,87 @@
1{ config, lib, pkgs, ... }:
2
3{
4 imports = [ ];
5
6 services.transmission = {
7 enable = true;
8 openFirewall = true;
9 openRPCPort = true;
10 user = "torrent";
11 settings = {
12 download-dir = "/torrents";
13 incomplete-dir = "/.incomplete";
14 rpc-bind-address = "0.0.0.0";
15 rpc-whitelist = "127.0.0.1,10.0.0.1,192.168.*.*,100.64.*.*";
16 };
17 };
18 services.nginx.virtualHosts."torrent.${config.networking.hostName}" = {
19 listen = [{ port = 80; addr = "0.0.0.0"; }];
20 locations."/" = {
21 proxyPass = "http://127.0.0.1:9091";
22 };
23 };
24
25 services.sonarr = {
26 enable = true;
27 openFirewall = true;
28 user = "torrent";
29 };
30 services.nginx.virtualHosts."sonarr.${config.networking.hostName}" = {
31 listen = [{ port = 80; addr = "0.0.0.0"; }];
32 locations."/" = {
33 proxyPass = "http://127.0.0.1:8989";
34 };
35 };
36
37 services.radarr = {
38 enable = true;
39 openFirewall = true;
40 user = "torrent";
41 };
42 services.nginx.virtualHosts."radarr.${config.networking.hostName}" = {
43 listen = [{ port = 80; addr = "0.0.0.0"; }];
44 locations."/" = {
45 proxyPass = "http://127.0.0.1:7878";
46 };
47 };
48
49 services.bazarr = {
50 enable = true;
51 openFirewall = true;
52 user = "torrent";
53 };
54 services.nginx.virtualHosts."bazarr.${config.networking.hostName}" = {
55 listen = [{ port = 80; addr = "0.0.0.0"; }];
56 locations."/" = {
57 proxyPass = "http://127.0.0.1:6767";
58 };
59 };
60
61 services.jackett = {
62 enable = true;
63 openFirewall = true;
64 user = "torrent";
65 };
66 services.nginx.virtualHosts."jackett.${config.networking.hostName}" = {
67 listen = [{ port = 80; addr = "0.0.0.0"; }];
68 locations."/" = {
69 proxyPass = "http://127.0.0.1:9117";
70 };
71 };
72
73 services.lidarr = {
74 enable = true;
75 openFirewall = true;
76 user = "torrent";
77 };
78 services.nginx.virtualHosts."lidarr.${config.networking.hostName}" = {
79 listen = [{ port = 80; addr = "0.0.0.0"; }];
80 locations."/" = {
81 proxyPass = "http://127.0.0.1:8686";
82 };
83 };
84
85}
86
87