aboutsummaryrefslogtreecommitdiff
path: root/hosts/mantis/home.nix
diff options
context:
space:
mode:
authorAkshay <[email protected]>2024-07-23 17:28:28 +0100
committerAkshay <[email protected]>2024-07-23 17:28:28 +0100
commitc7f07d8e847d1711708798848ad1b4ccfdfe36c1 (patch)
treefa61b7d9bfa83586b7316554a06ca748ea54418d /hosts/mantis/home.nix
parent3099f8b97a5be7b35b2eb03506adf1167270878e (diff)
reintro mantis
Diffstat (limited to 'hosts/mantis/home.nix')
-rw-r--r--hosts/mantis/home.nix91
1 files changed, 91 insertions, 0 deletions
diff --git a/hosts/mantis/home.nix b/hosts/mantis/home.nix
new file mode 100644
index 0000000..84a365f
--- /dev/null
+++ b/hosts/mantis/home.nix
@@ -0,0 +1,91 @@
1{ config
2, pkgs
3, theme
4, self
5, ...
6}:
7
8{
9
10 imports = [
11 ../../programs
12 ../../services
13 ../../x
14 # ./mail.nix
15 ];
16
17 home.stateVersion = "22.11";
18 home.username = "op";
19 home.homeDirectory = "/home/op";
20 home.extraOutputsToInstall = [ "man" ];
21 home.packages = with pkgs; [
22
23 # essentials
24 vim
25 weechat
26 firefox
27 qutebrowser
28 unzip
29 tmux
30 xclip
31 ripgrep
32 miniserve
33 pfetch
34 st
35 cmus
36 tree
37 w3m
38 noto-fonts-emoji
39 fd
40 du-dust
41 jq
42 libnotify
43 inotify-tools
44 pavucontrol
45 bc
46 killall
47
48 wget
49 curl
50
51 imagemagick
52 ffmpeg-full
53 mpv
54 slop
55 maim
56 arandr
57
58 # monitoring
59 stress
60 powertop
61
62 # input
63 xinput_calibrator
64 libinput
65
66 nixpkgs-fmt
67
68 ] ++ (import ../../scripts { inherit pkgs; });
69
70 xdg = {
71 userDirs = {
72 enable = true;
73 desktop = "\$HOME/desktop";
74 documents = "\$HOME/docs";
75 download = "\$HOME/dloads";
76 music = "\$HOME/music";
77 pictures = "\$HOME/pics";
78 videos = "\$HOME/vids";
79 };
80 };
81
82 xsession = {
83 enable = true;
84 windowManager.command = "2bwm";
85 initExtra = ''
86 ${pkgs.hsetroot}/bin/hsetroot -solid "${theme.base00}"
87 xrdb -load $HOME/.Xresources
88 '';
89 };
90
91}