aboutsummaryrefslogtreecommitdiff
path: root/programs/alacritty.nix
diff options
context:
space:
mode:
authorAkshay <[email protected]>2024-08-26 11:41:38 +0100
committerAkshay <[email protected]>2024-08-26 11:41:38 +0100
commite1358eef49165dad0b812ed4cfc9d0e9bcd76471 (patch)
tree653fb9bef3f9898206be091de8f180ff2c7bfa75 /programs/alacritty.nix
parentb0ec098b5c5166f0bc10b9508f50369fe290c5b0 (diff)
wayland updates
Diffstat (limited to 'programs/alacritty.nix')
-rw-r--r--programs/alacritty.nix63
1 files changed, 63 insertions, 0 deletions
diff --git a/programs/alacritty.nix b/programs/alacritty.nix
new file mode 100644
index 0000000..280c667
--- /dev/null
+++ b/programs/alacritty.nix
@@ -0,0 +1,63 @@
1{ config
2, pkgs
3, lib
4, theme
5, font
6, ...
7}:
8let
9
10 fontConfig = {
11 normal = { family = "${font.name}"; style = "Regular"; };
12 bold = { family = "${font.name}"; style = "Bold"; };
13 italic = { family = "${font.name}"; style = "Italic"; };
14 size = 10.0;
15 };
16in
17{
18 programs.alacritty = {
19 enable = true;
20 settings = {
21 env = {
22 TERM = "xterm-256color";
23 };
24 window = {
25 padding.x = 20;
26 padding.y = 20;
27 dynamic_padding = true;
28 decorations = "None";
29 };
30
31 font = fontConfig;
32
33 colors = {
34 primary = {
35 background = "${theme.base00}";
36 foreground = "${theme.base05}";
37 };
38 normal = {
39 black = "${theme.base00}";
40 red = "${theme.base08}";
41 green = "${theme.base0B}";
42 yellow = "${theme.base0A}";
43 blue = "${theme.base0D}";
44 magenta = "${theme.base0E}";
45 cyan = "${theme.base0C}";
46 white = "${theme.base05}";
47 };
48 bright = {
49 black = "${theme.base03}";
50 red = "${theme.base09}";
51 green = "${theme.base01}";
52 yellow = "${theme.base02}";
53 blue = "${theme.base04}";
54 magenta = "${theme.base06}";
55 cyan = "${theme.base0F}";
56 white = "${theme.base07}";
57 };
58 };
59
60 };
61 };
62}
63