aboutsummaryrefslogtreecommitdiff
path: root/programs/default.nix
diff options
context:
space:
mode:
authorAkshay <[email protected]>2021-09-26 16:56:36 +0100
committerAkshay <[email protected]>2021-09-26 16:56:36 +0100
commit5cdb4e421a809de51c3ebe8404e50d732721238b (patch)
tree73b71617c41b3e13edbf26035e821bb884d30441 /programs/default.nix
init
Diffstat (limited to 'programs/default.nix')
-rw-r--r--programs/default.nix51
1 files changed, 51 insertions, 0 deletions
diff --git a/programs/default.nix b/programs/default.nix
new file mode 100644
index 0000000..ba67638
--- /dev/null
+++ b/programs/default.nix
@@ -0,0 +1,51 @@
1{ config
2, pkgs
3, theme
4, ...
5}:
6
7{
8
9 imports = [
10 ./bash.nix
11 ./chromium.nix
12 ./feh.nix
13 ./git.nix
14 ./htop.nix
15 ./neovim.nix
16 ./readline.nix
17 ./tmux.nix
18 ./zathura.nix
19 ];
20
21 programs = {
22 msmtp.enable = true;
23 home-manager.enable = true;
24 mbsync.enable = true;
25 direnv = {
26 enable = true;
27 enableBashIntegration = true;
28 nix-direnv = {
29 enable = true;
30 useFlakes = true;
31 };
32 };
33 autojump = {
34 enable = true;
35 enableBashIntegration = true;
36 };
37 password-store = {
38 enable = true;
39 settings = {
40 PASSWORD_STORE_DIR = ''$HOME/.password-store'';
41 PASSWORD_STORE_KEY = "21532E14CF0840E438C36DED7164B95E9556624A";
42 PASSWORD_STORE_CLIP_TIME = "60";
43 };
44 };
45 nix-index = {
46 enable = true;
47 enableBashIntegration = true;
48 };
49 gpg.enable = true;
50 };
51}