aboutsummaryrefslogtreecommitdiff
path: root/programs/readline.nix
diff options
context:
space:
mode:
authorAkshay <[email protected]>2021-09-26 16:56:36 +0100
committerAkshay <[email protected]>2021-09-26 16:56:36 +0100
commit5cdb4e421a809de51c3ebe8404e50d732721238b (patch)
tree73b71617c41b3e13edbf26035e821bb884d30441 /programs/readline.nix
init
Diffstat (limited to 'programs/readline.nix')
-rw-r--r--programs/readline.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/programs/readline.nix b/programs/readline.nix
new file mode 100644
index 0000000..be43ace
--- /dev/null
+++ b/programs/readline.nix
@@ -0,0 +1,22 @@
1{ config
2, pkgs
3, ...
4}:
5
6{
7 programs.readline = {
8 enable = true;
9 bindings = {
10 "\\C-o" = ''"$HOME/scripts/tmux-fzf.sh\n"'';
11 "\\t" = "menu-complete";
12 "\\e[Z" = "menu-complete-backward";
13 };
14 variables = {
15 "completion-ignore-case" = "on";
16 "show-all-if-ambiguous" = "on";
17 "colored-stats" = "on";
18 "completion-display-width" = 4;
19 "enable-bracketed-paste" = "on";
20 };
21 };
22}