aboutsummaryrefslogtreecommitdiff
path: root/programs/rofi.nix
diff options
context:
space:
mode:
authorAkshay <[email protected]>2024-09-05 07:45:35 +0100
committerAkshay <[email protected]>2024-09-05 07:45:35 +0100
commit34196d256d2678c50b91005a6070580bfb417ce2 (patch)
treeb3a642612e01bf998e2330eb1c7e60b133aa4d5a /programs/rofi.nix
parente2f704d2f1e1ee4ecc678112af05927ce5a3db39 (diff)
setup rofi for wayland
Diffstat (limited to 'programs/rofi.nix')
-rw-r--r--programs/rofi.nix12
1 files changed, 5 insertions, 7 deletions
diff --git a/programs/rofi.nix b/programs/rofi.nix
index c140f63..b6105fc 100644
--- a/programs/rofi.nix
+++ b/programs/rofi.nix
@@ -35,17 +35,15 @@ let
35 35
36 inputbar.children = [ "entry" ]; 36 inputbar.children = [ "entry" ];
37 37
38 element.padding = 10;
39 entry = { 38 entry = {
40 padding = 10;
41 placeholder = "type to filter"; 39 placeholder = "type to filter";
42 }; 40 };
43 listview.border = 0; 41 listview.border = 0;
44 scrollbar.handle-width = 0; 42 scrollbar.handle-width = 0;
45 window = { 43 window = {
46 padding = 40; 44 padding = 40;
47 width = 800; 45 width = 600;
48 height = 600; 46 height = 400;
49 border = mkLiteral "3px solid"; 47 border = mkLiteral "3px solid";
50 border-color = mkLiteral theme.base01; 48 border-color = mkLiteral theme.base01;
51 }; 49 };
@@ -56,9 +54,9 @@ in
56 package = pkgs.rofi-wayland; 54 package = pkgs.rofi-wayland;
57 enable = true; 55 enable = true;
58 font = "${font.name} 12"; 56 font = "${font.name} 12";
59 location = "top-left"; 57 location = "center";
60 xoffset = 20; 58 # xoffset = 40;
61 yoffset = 20; 59 # yoffset = 40;
62 cycle = true; 60 cycle = true;
63 theme = rofi-theme; 61 theme = rofi-theme;
64 extraConfig = { 62 extraConfig = {