aboutsummaryrefslogtreecommitdiff
path: root/programs/zathura.nix
diff options
context:
space:
mode:
authorAkshay <[email protected]>2021-09-26 16:56:36 +0100
committerAkshay <[email protected]>2021-09-26 16:56:36 +0100
commit5cdb4e421a809de51c3ebe8404e50d732721238b (patch)
tree73b71617c41b3e13edbf26035e821bb884d30441 /programs/zathura.nix
init
Diffstat (limited to 'programs/zathura.nix')
-rw-r--r--programs/zathura.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/programs/zathura.nix b/programs/zathura.nix
new file mode 100644
index 0000000..5e5c8ce
--- /dev/null
+++ b/programs/zathura.nix
@@ -0,0 +1,37 @@
1{ config
2, pkgs
3, theme
4, ...
5}:
6
7with theme;
8{
9 programs.zathura = {
10 enable = true;
11 options = {
12 incremental-search = "true";
13 recolor = "true";
14 default-bg = base00;
15 default-fg = base05;
16 completion-bg = base00;
17 completion-fg = base05;
18 completion-highlight-bg = base0E;
19 completion-highlight-fg = base05;
20 statusbar-bg = base00;
21 statusbar-fg = base05;
22 inputbar-bg = base00;
23 inputbar-fg = base05;
24 recolor-darkcolor = base05;
25 recolor-lightcolor = base00;
26 window-height = "800";
27 window-width = "600";
28 adjust-open = "width";
29 smooth-scroll = "true";
30 statusbar-home-tilde = "true";
31 statusbar-h-padding = "50";
32 statusbar-v-padding = "50";
33 guioptions = "s";
34 font = "Input 10";
35 };
36 };
37}