aboutsummaryrefslogtreecommitdiff
path: root/services/dunst.nix
diff options
context:
space:
mode:
authorAkshay <[email protected]>2021-09-26 16:56:36 +0100
committerAkshay <[email protected]>2021-09-26 16:56:36 +0100
commit5cdb4e421a809de51c3ebe8404e50d732721238b (patch)
tree73b71617c41b3e13edbf26035e821bb884d30441 /services/dunst.nix
init
Diffstat (limited to 'services/dunst.nix')
-rw-r--r--services/dunst.nix71
1 files changed, 71 insertions, 0 deletions
diff --git a/services/dunst.nix b/services/dunst.nix
new file mode 100644
index 0000000..8882ade
--- /dev/null
+++ b/services/dunst.nix
@@ -0,0 +1,71 @@
1{ config
2, pkgs
3, theme
4, ...
5}:
6
7with theme;
8{
9 services.dunst = {
10 enable = true;
11 settings = {
12 global = {
13 font = "Input 9";
14 allow_markup = "no";
15 format = "%s\n%b";
16 sort = "yes";
17 indicate_hidden = "yes";
18 alignment = "right";
19 bounce_freq = "0";
20 show_age_threshold = "60";
21 word_wrap = "yes";
22 ignore_newline = "no";
23 geometry = "300x8-20+20";
24 shrink = "yes";
25 transparency = "0";
26 idle_threshold = "120";
27 monitor = "0";
28 follow = "mouse";
29 sticky_history = "yes";
30 history_length = "20";
31 show_indicators = "yes";
32 line_height = "0";
33 separator_height = "0";
34 padding = "20";
35 horizontal_padding = "20";
36 separator_color = "auto";
37 startup_notification = "true";
38 };
39
40 urgency_normal = {
41 background = base00;
42 foreground = base05;
43 timeout = 10;
44 };
45
46 urgency_low = {
47 background = base00;
48 foreground = base05;
49 timeout = 2;
50 };
51
52 urgency_critical = {
53 background = base00;
54 foreground = base05;
55 timeout = 0;
56 };
57
58 frame = {
59 width = 2;
60 color = base01;
61 };
62
63 shortcuts = {
64 close = "ctrl+space";
65 close_all = "ctrl+shift+space";
66 history = "ctrl+grave";
67 context = "ctrl+shift+period";
68 };
69 };
70 };
71}