aboutsummaryrefslogtreecommitdiff
path: root/services/picom.nix
diff options
context:
space:
mode:
authorAkshay <[email protected]>2021-09-26 16:56:36 +0100
committerAkshay <[email protected]>2021-09-26 16:56:36 +0100
commit5cdb4e421a809de51c3ebe8404e50d732721238b (patch)
tree73b71617c41b3e13edbf26035e821bb884d30441 /services/picom.nix
init
Diffstat (limited to 'services/picom.nix')
-rw-r--r--services/picom.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/services/picom.nix b/services/picom.nix
new file mode 100644
index 0000000..67605d1
--- /dev/null
+++ b/services/picom.nix
@@ -0,0 +1,18 @@
1{ config
2, pkgs
3, ...
4}:
5
6{
7 services.picom = {
8 enable = true;
9 backend = "glx";
10 fade = true;
11 fadeDelta = 10;
12 fadeSteps = [ "0.04" "0.04" ];
13 inactiveDim = "0.0";
14 shadow = false;
15 shadowOffsets = [ (-60) (-60) ];
16 shadowOpacity = "0.20";
17 };
18}