aboutsummaryrefslogtreecommitdiff
path: root/services/sxhkd.nix
diff options
context:
space:
mode:
authorAkshay <[email protected]>2021-09-26 16:56:36 +0100
committerAkshay <[email protected]>2021-09-26 16:56:36 +0100
commit5cdb4e421a809de51c3ebe8404e50d732721238b (patch)
tree73b71617c41b3e13edbf26035e821bb884d30441 /services/sxhkd.nix
init
Diffstat (limited to 'services/sxhkd.nix')
-rw-r--r--services/sxhkd.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/services/sxhkd.nix b/services/sxhkd.nix
new file mode 100644
index 0000000..8658875
--- /dev/null
+++ b/services/sxhkd.nix
@@ -0,0 +1,17 @@
1{ config
2, pkgs
3, theme
4, ...
5}:
6
7{
8 services.sxhkd = {
9 enable = true;
10 keybindings = {
11 "XF86Audio{Lower,Raise}Volume" = "${pkgs.alsaUtils}/bin/amixer sset Master 2%{-,+}";
12 "XF86AudioMute" = "${pkgs.alsaUtils}/bin/amixer sset Master toggle";
13 "XF86MonBrightness{Down,Up}" = "${pkgs.light}/bin/light -{U,A} 5";
14 "super + Escape" = "pkill -USR1 -x sxhkd";
15 };
16 };
17}