aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix24
1 files changed, 1 insertions, 23 deletions
diff --git a/flake.nix b/flake.nix
index 55ed146..16326a5 100644
--- a/flake.nix
+++ b/flake.nix
@@ -56,27 +56,6 @@
56 formatter."x86_64-linux" = nixpkgs.legacyPackages."x86_64-linux".nixpkgs-fmt; 56 formatter."x86_64-linux" = nixpkgs.legacyPackages."x86_64-linux".nixpkgs-fmt;
57 57
58 nixosConfigurations = { 58 nixosConfigurations = {
59 olive = nixpkgs.lib.nixosSystem {
60 system = "x86_64-linux";
61 modules = [
62 ({ config = { nix.registry.nixpkgs.flake = nixpkgs; }; })
63 {
64 imports = [ ./hosts/olive/configuration.nix ];
65 _module.args.self = self;
66 }
67 home-manager.nixosModules.home-manager
68 {
69 home-manager.useGlobalPkgs = true;
70 home-manager.useUserPackages = true;
71 home-manager.users.np = {
72 imports = [ ./home.nix ];
73 _module.args.self = self;
74 _module.args.inputs = inputs;
75 _module.args.theme = import ./theme;
76 };
77 }
78 ];
79 };
80 59
81 myrtle = nixpkgs.lib.nixosSystem { 60 myrtle = nixpkgs.lib.nixosSystem {
82 system = "x86_64-linux"; 61 system = "x86_64-linux";
@@ -91,7 +70,7 @@
91 home-manager.useGlobalPkgs = true; 70 home-manager.useGlobalPkgs = true;
92 home-manager.useUserPackages = true; 71 home-manager.useUserPackages = true;
93 home-manager.users.np = { 72 home-manager.users.np = {
94 imports = [ ./home.nix ]; 73 imports = [ ./hosts/myrtle/home.nix ];
95 _module.args.self = self; 74 _module.args.self = self;
96 _module.args.inputs = inputs; 75 _module.args.inputs = inputs;
97 _module.args.theme = import ./theme; 76 _module.args.theme = import ./theme;
@@ -110,7 +89,6 @@
110 imports = [ ./hosts/mantis/configuration.nix ]; 89 imports = [ ./hosts/mantis/configuration.nix ];
111 _module.args.self = self; 90 _module.args.self = self;
112 } 91 }
113 flaresolverr.nixosModules.default
114 ]; 92 ];
115 }; 93 };
116 94