aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix17
1 files changed, 16 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 07b27e1..06ce985 100644
--- a/flake.nix
+++ b/flake.nix
@@ -3,13 +3,26 @@
3 3
4 inputs = { 4 inputs = {
5 nixpkgs.url = "github:NixOS/nixpkgs/nixos-21.11"; 5 nixpkgs.url = "github:NixOS/nixpkgs/nixos-21.11";
6
6 nixos-hardware.url = "github:nixos/nixos-hardware"; 7 nixos-hardware.url = "github:nixos/nixos-hardware";
8
7 home-manager = { 9 home-manager = {
8 url = "github:nix-community/home-manager/release-21.11"; 10 url = "github:nix-community/home-manager/release-21.11";
9 inputs.nixpkgs.follows = "nixpkgs"; 11 inputs.nixpkgs.follows = "nixpkgs";
10 }; 12 };
13
11 neovim.url = "github:nix-community/neovim-nightly-overlay"; 14 neovim.url = "github:nix-community/neovim-nightly-overlay";
12 statix.url = "github:nerdypepper/statix"; 15
16 statix = {
17 url = "git+https://git.peppe.rs/languages/statix";
18 inputs.nixpkgs.follows = "nixpkgs";
19 };
20
21 prompt = {
22 url = "git+https://git.peppe.rs/cli/prompt";
23 inputs.nixpkgs.follows = "nixpkgs";
24 };
25
13 }; 26 };
14 27
15 outputs = 28 outputs =
@@ -19,12 +32,14 @@
19 , home-manager 32 , home-manager
20 , neovim 33 , neovim
21 , statix 34 , statix
35 , prompt
22 , ... 36 , ...
23 } @ inputs: { 37 } @ inputs: {
24 38
25 overlays = { 39 overlays = {
26 nvim-nightly = neovim.overlay; 40 nvim-nightly = neovim.overlay;
27 statix = statix.overlay; 41 statix = statix.overlay;
42 prompt = prompt.overlay;
28 }; 43 };
29 44
30 nixosConfigurations = { 45 nixosConfigurations = {