aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix5
1 files changed, 1 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index ce35ce8..8293654 100644
--- a/flake.nix
+++ b/flake.nix
@@ -11,8 +11,6 @@
11 inputs.nixpkgs.follows = "nixpkgs"; 11 inputs.nixpkgs.follows = "nixpkgs";
12 }; 12 };
13 13
14 neovim.url = "github:nix-community/neovim-nightly-overlay";
15
16 statix = { 14 statix = {
17 url = "git+https://git.peppe.rs/languages/statix"; 15 url = "git+https://git.peppe.rs/languages/statix";
18 inputs.nixpkgs.follows = "nixpkgs"; 16 inputs.nixpkgs.follows = "nixpkgs";
@@ -30,14 +28,12 @@
30 , nixpkgs 28 , nixpkgs
31 , nixos-hardware 29 , nixos-hardware
32 , home-manager 30 , home-manager
33 , neovim
34 , statix 31 , statix
35 , prompt 32 , prompt
36 , ... 33 , ...
37 } @ inputs: { 34 } @ inputs: {
38 35
39 overlays = { 36 overlays = {
40 nvim-nightly = neovim.overlay;
41 statix = statix.overlay; 37 statix = statix.overlay;
42 prompt = prompt.overlay; 38 prompt = prompt.overlay;
43 }; 39 };
@@ -46,6 +42,7 @@
46 olive = nixpkgs.lib.nixosSystem { 42 olive = nixpkgs.lib.nixosSystem {
47 system = "x86_64-linux"; 43 system = "x86_64-linux";
48 modules = [ 44 modules = [
45 ({ config = { nix.registry.nixpkgs.flake = nixpkgs; }; })
49 { 46 {
50 imports = [ ./hosts/olive/configuration.nix ]; 47 imports = [ ./hosts/olive/configuration.nix ];
51 _module.args.self = self; 48 _module.args.self = self;