diff options
Diffstat (limited to 'home.nix')
-rw-r--r-- | home.nix | 88 |
1 files changed, 88 insertions, 0 deletions
diff --git a/home.nix b/home.nix new file mode 100644 index 0000000..93f66ad --- /dev/null +++ b/home.nix | |||
@@ -0,0 +1,88 @@ | |||
1 | { config | ||
2 | , pkgs | ||
3 | , theme | ||
4 | , ... | ||
5 | }: | ||
6 | |||
7 | { | ||
8 | |||
9 | imports = [ | ||
10 | ./programs | ||
11 | ./services | ||
12 | # ./scripts | ||
13 | ./x | ||
14 | ./mail.nix | ||
15 | ]; | ||
16 | |||
17 | home.stateVersion = "21.05"; | ||
18 | home.username = "np"; | ||
19 | home.homeDirectory = "/home/np"; | ||
20 | home.packages = with pkgs; [ | ||
21 | |||
22 | vim | ||
23 | unzip | ||
24 | curl | ||
25 | tmux | ||
26 | weechat | ||
27 | rofi | ||
28 | firefox | ||
29 | xclip | ||
30 | ripgrep | ||
31 | ccls | ||
32 | miniserve | ||
33 | rnix-lsp | ||
34 | pfetch | ||
35 | st | ||
36 | arandr | ||
37 | imagemagick | ||
38 | ffmpeg | ||
39 | maim | ||
40 | wget | ||
41 | cmus | ||
42 | tree | ||
43 | rxvt-unicode | ||
44 | neomutt | ||
45 | mpv | ||
46 | nodePackages.bash-language-server | ||
47 | gitAndTools.delta | ||
48 | w3m | ||
49 | noto-fonts-emoji | ||
50 | ripgrep-all | ||
51 | urlview | ||
52 | slop | ||
53 | gimp | ||
54 | fd | ||
55 | du-dust | ||
56 | jq | ||
57 | |||
58 | # meta | ||
59 | nixpkgs-review | ||
60 | nixpkgs-fmt | ||
61 | nix-prefetch-scripts | ||
62 | nix-bash-completions | ||
63 | |||
64 | ]; | ||
65 | |||
66 | xdg = { | ||
67 | userDirs = { | ||
68 | enable = true; | ||
69 | desktop = "\$HOME/desktop"; | ||
70 | documents = "\$HOME/docs"; | ||
71 | download = "\$HOME/dloads"; | ||
72 | music = "\$HOME/music"; | ||
73 | pictures = "\$HOME/pics"; | ||
74 | videos = "\$HOME/vids"; | ||
75 | }; | ||
76 | }; | ||
77 | |||
78 | xsession = { | ||
79 | enable = true; | ||
80 | windowManager.command = "2bwm"; | ||
81 | initExtra = '' | ||
82 | ${pkgs.hsetroot}/bin/hsetroot -solid "#000" | ||
83 | xrdb -load $HOME/.Xresources | ||
84 | setxkbmap -option 'caps:swapescape' | ||
85 | ''; | ||
86 | }; | ||
87 | |||
88 | } | ||