aboutsummaryrefslogtreecommitdiff
path: root/hosts/laurel/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/laurel/configuration.nix')
-rw-r--r--hosts/laurel/configuration.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/hosts/laurel/configuration.nix b/hosts/laurel/configuration.nix
index d0edee3..f23a41a 100644
--- a/hosts/laurel/configuration.nix
+++ b/hosts/laurel/configuration.nix
@@ -61,6 +61,25 @@
61 services.openssh.enable = true; 61 services.openssh.enable = true;
62 services.tailscale.enable = true; 62 services.tailscale.enable = true;
63 63
64 services.invidious = {
65 enable = true;
66 port = 3333;
67 domain = "tube.laurel";
68 settings = {
69 db = {
70 user = "invidious";
71 dbname = "invidious";
72 };
73 };
74 };
75 services.nginx.virtualHosts."tube.laurel" = {
76 listen = [{ port = 80; addr = "0.0.0.0"; }];
77 locations."/" = {
78 proxyPass = "http://127.0.0.1:${config.services.invidious.port}";
79 proxyWebsockets = true;
80 };
81 };
82
64 nix.settings.experimental-features = [ "nix-command" "flakes" ]; 83 nix.settings.experimental-features = [ "nix-command" "flakes" ];
65 84
66 # This option defines the first version of NixOS you have installed on this particular machine, 85 # This option defines the first version of NixOS you have installed on this particular machine,