aboutsummaryrefslogtreecommitdiff
path: root/hosts/laurel/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/laurel/hardware-configuration.nix')
-rw-r--r--hosts/laurel/hardware-configuration.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/hosts/laurel/hardware-configuration.nix b/hosts/laurel/hardware-configuration.nix
new file mode 100644
index 0000000..142c4a7
--- /dev/null
+++ b/hosts/laurel/hardware-configuration.nix
@@ -0,0 +1,43 @@
1# Do not modify this file! It was generated by ‘nixos-generate-config’
2# and may be overwritten by future invocations. Please make changes
3# to /etc/nixos/configuration.nix instead.
4{ config, lib, pkgs, modulesPath, ... }:
5
6{
7 imports =
8 [
9 (modulesPath + "/installer/scan/not-detected.nix")
10 ];
11
12 boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "usbhid" "usb_storage" "sd_mod" ];
13 boot.initrd.kernelModules = [ ];
14 boot.kernelModules = [ "kvm-intel" ];
15 boot.extraModulePackages = [ ];
16
17 fileSystems."/" =
18 {
19 device = "/dev/disk/by-uuid/0a4289c5-753f-410a-aca0-0d70b448dffc";
20 fsType = "ext4";
21 };
22
23 fileSystems."/boot" =
24 {
25 device = "/dev/disk/by-uuid/FDC2-EFD1";
26 fsType = "vfat";
27 };
28
29 swapDevices =
30 [{ device = "/dev/disk/by-uuid/22b596ba-93ef-4a41-8e4c-292e5baa36e8"; }];
31
32 # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
33 # (the default) this is the recommended approach. When using systemd-networkd it's
34 # still possible to use this option, but it's recommended to use it in conjunction
35 # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
36 networking.useDHCP = lib.mkDefault true;
37 # networking.interfaces.enp1s0.useDHCP = lib.mkDefault true;
38 # networking.interfaces.wlp2s0.useDHCP = lib.mkDefault true;
39
40 nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
41 hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
42}
43