aboutsummaryrefslogtreecommitdiff
path: root/hosts/mantis/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/mantis/configuration.nix')
-rw-r--r--hosts/mantis/configuration.nix89
1 files changed, 15 insertions, 74 deletions
diff --git a/hosts/mantis/configuration.nix b/hosts/mantis/configuration.nix
index acc2a49..c774eef 100644
--- a/hosts/mantis/configuration.nix
+++ b/hosts/mantis/configuration.nix
@@ -1,6 +1,6 @@
1# https://search.nixos.org/options and in the NixOS manual (`nixos-help`). 1# https://search.nixos.org/options and in the NixOS manual (`nixos-help`).
2 2
3{ config, lib, pkgs, ... }: 3{ config, lib, pkgs, self, ... }:
4 4
5{ 5{
6 imports = 6 imports =
@@ -12,58 +12,19 @@
12 boot.loader.systemd-boot.enable = true; 12 boot.loader.systemd-boot.enable = true;
13 boot.loader.efi.canTouchEfiVariables = true; 13 boot.loader.efi.canTouchEfiVariables = true;
14 14
15 networking.hostName = "mantis"; # Define your hostname. 15 networking.hostName = "mantis";
16 # Pick only one of the below networking options.
17 # networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
18 # networking.networkmanager.enable = true; # Easiest to use and most distros use this by default.
19
20 # Set your time zone.
21 time.timeZone = "Europe/London"; 16 time.timeZone = "Europe/London";
22 17
23 # Configure network proxy if necessary 18 nixpkgs.overlays = with self.overlays; [
24 # networking.proxy.default = "http://user:password@proxy:port/"; 19 prompt
25 # networking.proxy.noProxy = "127.0.0.1,localhost,internal.domain"; 20 better-text-objs
26 21 vim-colors-plain
27 # Select internationalisation properties. 22 ];
28 # i18n.defaultLocale = "en_US.UTF-8";
29 # console = {
30 # font = "Lat2-Terminus16";
31 # keyMap = "us";
32 # useXkbConfig = true; # use xkb.options in tty.
33 # };
34
35 # Enable the X11 windowing system.
36 services.xserver.enable = true;
37
38
39 # Enable the GNOME Desktop Environment.
40 services.xserver.displayManager.gdm.enable = true;
41 services.xserver.desktopManager.gnome.enable = true;
42
43
44 # Configure keymap in X11
45 # services.xserver.xkb.layout = "us";
46 # services.xserver.xkb.options = "eurosign:e,caps:escape";
47
48 # Enable CUPS to print documents.
49 # services.printing.enable = true;
50
51 # Enable sound.
52 # hardware.pulseaudio.enable = true;
53 # OR
54 # services.pipewire = {
55 # enable = true;
56 # pulse.enable = true;
57 # };
58 23
59 # Enable touchpad support (enabled default in most desktopManager).
60 services.xserver.libinput.enable = true;
61 services.tailscale.enable = true;
62 24
63 # Define a user account. Don't forget to set a password with ‘passwd’.
64 users.users.op = { 25 users.users.op = {
65 isNormalUser = true; 26 isNormalUser = true;
66 extraGroups = [ "wheel" ]; # Enable ‘sudo’ for the user. 27 extraGroups = [ "wheel" ];
67 packages = with pkgs; [ 28 packages = with pkgs; [
68 qutebrowser 29 qutebrowser
69 tree 30 tree
@@ -72,39 +33,19 @@
72 home = "/home/op"; 33 home = "/home/op";
73 }; 34 };
74 35
75 # List packages installed in system profile. To search, run:
76 # $ nix search wget
77 environment.systemPackages = with pkgs; [ 36 environment.systemPackages = with pkgs; [
78 vim # Do not forget to add an editor to edit configuration.nix! The Nano editor is also installed by default. 37 man-pages
79 wget 38 man-pages-posix
80 git 39 (lib.hiPrio pkgs.bashInteractive_5)
81 ]; 40 ];
82 41
83 # Some programs need SUID wrappers, can be configured further or are 42 services = {
84 # started in user sessions. 43 openssh.enable = true;
85 # programs.mtr.enable = true; 44 tailscale.enable = true;
86 # programs.gnupg.agent = { 45 };
87 # enable = true;
88 # enableSSHSupport = true;
89 # };
90
91 # List services that you want to enable:
92 46
93 # Enable the OpenSSH daemon.
94 services.openssh.enable = true;
95 nix.settings.experimental-features = [ "nix-command" "flakes" ]; 47 nix.settings.experimental-features = [ "nix-command" "flakes" ];
96 48
97 # Open ports in the firewall.
98 # networking.firewall.allowedTCPPorts = [ ... ];
99 # networking.firewall.allowedUDPPorts = [ ... ];
100 # Or disable the firewall altogether.
101 # networking.firewall.enable = false;
102
103 # Copy the NixOS configuration file and link it from the resulting system
104 # (/run/current-system/configuration.nix). This is useful in case you
105 # accidentally delete configuration.nix.
106 # system.copySystemConfiguration = true;
107
108 # This option defines the first version of NixOS you have installed on this particular machine, 49 # This option defines the first version of NixOS you have installed on this particular machine,
109 # and is used to maintain compatibility with application data (e.g. databases) created on older NixOS versions. 50 # and is used to maintain compatibility with application data (e.g. databases) created on older NixOS versions.
110 # 51 #