aboutsummaryrefslogtreecommitdiff
path: root/hosts/mantis/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/mantis/hardware-configuration.nix')
-rw-r--r--hosts/mantis/hardware-configuration.nix22
1 files changed, 7 insertions, 15 deletions
diff --git a/hosts/mantis/hardware-configuration.nix b/hosts/mantis/hardware-configuration.nix
index 6afcb08..3f04a4a 100644
--- a/hosts/mantis/hardware-configuration.nix
+++ b/hosts/mantis/hardware-configuration.nix
@@ -5,35 +5,28 @@
5 5
6{ 6{
7 imports = 7 imports =
8 [ 8 [ (modulesPath + "/installer/scan/not-detected.nix")
9 (modulesPath + "/installer/scan/not-detected.nix")
10 ]; 9 ];
11 10
12 boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "usbhid" "usb_storage" "sd_mod" ]; 11 boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "nvme" "usbhid" "usb_storage" "sd_mod" ];
13 boot.initrd.kernelModules = [ ]; 12 boot.initrd.kernelModules = [ ];
14 boot.kernelModules = [ "kvm-intel" ]; 13 boot.kernelModules = [ "kvm-intel" ];
15 boot.extraModulePackages = [ ]; 14 boot.extraModulePackages = [ ];
16 15
17 fileSystems."/" = 16 fileSystems."/" =
18 { 17 { device = "/dev/disk/by-uuid/efd94de4-c3fa-4a3b-98f9-66ccfb8479b9";
19 device = "/dev/disk/by-uuid/e3eda8a2-b5fe-4458-988c-48579a7cc6c6";
20 fsType = "ext4";
21 };
22
23 fileSystems."/servarr" =
24 {
25 device = "/dev/sdb";
26 fsType = "ext4"; 18 fsType = "ext4";
27 }; 19 };
28 20
29 fileSystems."/boot" = 21 fileSystems."/boot" =
30 { 22 { device = "/dev/disk/by-uuid/5BBB-E6FE";
31 device = "/dev/disk/by-uuid/A170-EC57";
32 fsType = "vfat"; 23 fsType = "vfat";
24 options = [ "fmask=0022" "dmask=0022" ];
33 }; 25 };
34 26
35 swapDevices = 27 swapDevices =
36 [{ device = "/dev/disk/by-uuid/61cb6a91-b916-40b9-b231-c04378629d90"; }]; 28 [ { device = "/dev/disk/by-uuid/65faea2e-c2ce-4ec2-8aca-e09e5073676b"; }
29 ];
37 30
38 # Enables DHCP on each ethernet and wireless interface. In case of scripted networking 31 # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
39 # (the default) this is the recommended approach. When using systemd-networkd it's 32 # (the default) this is the recommended approach. When using systemd-networkd it's
@@ -41,7 +34,6 @@
41 # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`. 34 # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
42 networking.useDHCP = lib.mkDefault true; 35 networking.useDHCP = lib.mkDefault true;
43 # networking.interfaces.enp2s0.useDHCP = lib.mkDefault true; 36 # networking.interfaces.enp2s0.useDHCP = lib.mkDefault true;
44 # networking.interfaces.wlp3s0.useDHCP = lib.mkDefault true;
45 37
46 nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux"; 38 nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
47 hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware; 39 hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;