aboutsummaryrefslogtreecommitdiff
path: root/hosts/myrtle/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/myrtle/configuration.nix')
-rw-r--r--hosts/myrtle/configuration.nix27
1 files changed, 21 insertions, 6 deletions
diff --git a/hosts/myrtle/configuration.nix b/hosts/myrtle/configuration.nix
index be9852e..27b16ce 100644
--- a/hosts/myrtle/configuration.nix
+++ b/hosts/myrtle/configuration.nix
@@ -14,6 +14,7 @@
14 boot.kernelParams = [ 14 boot.kernelParams = [
15 # "i915.modeset=0" 15 # "i915.modeset=0"
16 # "intel_pstate=disable" 16 # "intel_pstate=disable"
17 "ibt=off"
17 ]; 18 ];
18 19
19 networking = { 20 networking = {
@@ -104,10 +105,6 @@
104 105
105 hardware = { 106 hardware = {
106 opengl.driSupport = true; 107 opengl.driSupport = true;
107 # pulseaudio = {
108 # enable = true;
109 # package = pkgs.pulseaudioFull;
110 # };
111 bluetooth = { 108 bluetooth = {
112 enable = true; 109 enable = true;
113 powerOnBoot = true; 110 powerOnBoot = true;
@@ -126,7 +123,7 @@
126 }; 123 };
127 sensor.iio.enable = true; # enable screen autorotate 124 sensor.iio.enable = true; # enable screen autorotate
128 asus.battery = { 125 asus.battery = {
129 chargeUpto = 80; 126 chargeUpto = 100;
130 }; 127 };
131 }; 128 };
132 129
@@ -187,16 +184,34 @@
187 pulse.enable = true; 184 pulse.enable = true;
188 }; 185 };
189 186
187 signald = {
188 enable = true;
189 group = "signald";
190 };
191
192 bitlbee = {
193 enable = true;
194 libpurple_plugins = [
195 pkgs.purple-signald
196 ];
197 portNumber = 8888;
198 };
190 }; 199 };
191 200
192 systemd.sleep.extraConfig = '' 201 systemd.sleep.extraConfig = ''
193 HibernateMode=shutdown 202 HibernateMode=suspend
194 ''; 203 '';
195 204
196 virtualisation.docker.enable = true; 205 virtualisation.docker.enable = true;
197 virtualisation.virtualbox.host.enable = true; 206 virtualisation.virtualbox.host.enable = true;
198 users.extraGroups.vboxusers.members = [ "np" ]; 207 users.extraGroups.vboxusers.members = [ "np" ];
199 208
209 security.sudo.extraRules = [
210 {
211 users = [ "np" ];
212 commands = map (cmd: "${pkgs.systemd}/bin/systemctl ${cmd}") [ "poweroff" "suspend" "reboot" ];
213 }
214 ];
200 215
201 users.users.np = { 216 users.users.np = {
202 isNormalUser = true; 217 isNormalUser = true;