aboutsummaryrefslogtreecommitdiff
path: root/hosts/myrtle/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/myrtle/configuration.nix')
-rw-r--r--hosts/myrtle/configuration.nix31
1 files changed, 24 insertions, 7 deletions
diff --git a/hosts/myrtle/configuration.nix b/hosts/myrtle/configuration.nix
index 27b16ce..f554069 100644
--- a/hosts/myrtle/configuration.nix
+++ b/hosts/myrtle/configuration.nix
@@ -99,6 +99,8 @@
99 programs = { 99 programs = {
100 light.enable = true; 100 light.enable = true;
101 adb.enable = true; 101 adb.enable = true;
102 steam.enable = true;
103 gamemode.enable = true;
102 }; 104 };
103 105
104 # sound.enable = true; 106 # sound.enable = true;
@@ -123,7 +125,7 @@
123 }; 125 };
124 sensor.iio.enable = true; # enable screen autorotate 126 sensor.iio.enable = true; # enable screen autorotate
125 asus.battery = { 127 asus.battery = {
126 chargeUpto = 100; 128 chargeUpto = 80;
127 }; 129 };
128 }; 130 };
129 131
@@ -150,6 +152,7 @@
150 Option "AllowIndirectGLXProtocol" "off" 152 Option "AllowIndirectGLXProtocol" "off"
151 Option "TripleBuffer" "on" 153 Option "TripleBuffer" "on"
152 ''; 154 '';
155
153 }; 156 };
154 157
155 openssh = { 158 openssh = {
@@ -206,12 +209,26 @@
206 virtualisation.virtualbox.host.enable = true; 209 virtualisation.virtualbox.host.enable = true;
207 users.extraGroups.vboxusers.members = [ "np" ]; 210 users.extraGroups.vboxusers.members = [ "np" ];
208 211
209 security.sudo.extraRules = [ 212 security.sudo = {
210 { 213 enable = true;
211 users = [ "np" ]; 214 extraRules = [{
212 commands = map (cmd: "${pkgs.systemd}/bin/systemctl ${cmd}") [ "poweroff" "suspend" "reboot" ]; 215 commands = [
213 } 216 {
214 ]; 217 command = "${pkgs.systemd}/bin/systemctl suspend";
218 options = [ "NOPASSWD" ];
219 }
220 {
221 command = "${pkgs.systemd}/bin/reboot";
222 options = [ "NOPASSWD" ];
223 }
224 {
225 command = "${pkgs.systemd}/bin/poweroff";
226 options = [ "NOPASSWD" ];
227 }
228 ];
229 groups = [ "wheel" ];
230 }];
231 };
215 232
216 users.users.np = { 233 users.users.np = {
217 isNormalUser = true; 234 isNormalUser = true;