aboutsummaryrefslogtreecommitdiff
path: root/hosts/myrtle/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/myrtle/configuration.nix')
-rw-r--r--hosts/myrtle/configuration.nix57
1 files changed, 29 insertions, 28 deletions
diff --git a/hosts/myrtle/configuration.nix b/hosts/myrtle/configuration.nix
index ff64e80..7a7d9d1 100644
--- a/hosts/myrtle/configuration.nix
+++ b/hosts/myrtle/configuration.nix
@@ -91,51 +91,52 @@
91 package = pkgs.pulseaudioFull; 91 package = pkgs.pulseaudioFull;
92 # extraConfig = "load-module module-bluetooth-policy auto_switch=2"; 92 # extraConfig = "load-module module-bluetooth-policy auto_switch=2";
93 }; 93 };
94 # opengl.enable = true;
95 bluetooth = { 94 bluetooth = {
96 enable = true; 95 enable = true;
97 powerOnBoot = true; 96 powerOnBoot = true;
98 }; 97 };
99 # nvidia = {
100 # prime = {
101 # offload.enable = true;
102 # nvidiaBusId = "PCI:1:0:0";
103 # intelBusId = "PCI:0:2:0";
104 # };
105 # };
106 }; 98 };
107 99
108 100
109 services.xserver = { 101 services = {
110 enable = true; 102 xserver = {
111 layout = "us"; 103 enable = true;
112 # videoDrivers = [ "nvidia" ]; 104 layout = "us";
113 displayManager.startx.enable = true; 105 # videoDrivers = [ "nvidia" ];
114 libinput.enable = true; 106 displayManager.startx.enable = true;
115 }; 107 libinput.enable = true;
108 };
116 109
117 services.asusd = { 110 asusd = {
118 enable = true; 111 enable = true;
119 enableUserService = true; 112 enableUserService = true;
120 }; 113 };
121 services.supergfxd.enable = true; 114 supergfxd.enable = true;
122 115
123 services.logind.extraConfig = '' 116 logind.extraConfig = ''
124 HandlePowerKey=suspend-then-hibernate 117 HandlePowerKey=suspend-then-hibernate
125 HandlePowerKeyLongPress=poweroff 118 HandlePowerKeyLongPress=poweroff
126 ''; 119 '';
127 120
128 powerManagement.powertop.enable = true; 121 auto-cpufreq.enable = true;
129 services.batteryNotifier = { 122 batteryNotifier = {
123 enable = true;
124 notifyCapacity = 20;
125 suspendCapacity = 5;
126 };
127 };
128
129 powerManagement = {
130 enable = true; 130 enable = true;
131 notifyCapacity = 20; 131 powertop.enable = true;
132 suspendCapacity = 5;
133 }; 132 };
134 133
135 systemd.sleep.extraConfig = '' 134 systemd.sleep.extraConfig = ''
136 HibernateMode=shutdown 135 HibernateMode=shutdown
137 ''; 136 '';
138 137
138 virtualisation.docker.enable = true;
139
139 users.users.np = { 140 users.users.np = {
140 isNormalUser = true; 141 isNormalUser = true;
141 home = "/home/np"; 142 home = "/home/np";