aboutsummaryrefslogtreecommitdiff
path: root/hosts/myrtle/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/myrtle/hardware-configuration.nix')
-rw-r--r--hosts/myrtle/hardware-configuration.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/hosts/myrtle/hardware-configuration.nix b/hosts/myrtle/hardware-configuration.nix
new file mode 100644
index 0000000..86638d2
--- /dev/null
+++ b/hosts/myrtle/hardware-configuration.nix
@@ -0,0 +1,40 @@
1# Do not modify this file! It was generated by ‘nixos-generate-config’
2# and may be overwritten by future invocations. Please make changes
3# to /etc/nixos/configuration.nix instead.
4{ config, lib, pkgs, modulesPath, ... }:
5
6{
7 imports =
8 [ (modulesPath + "/installer/scan/not-detected.nix")
9 ];
10
11 boot.initrd.availableKernelModules = [ "xhci_pci" "thunderbolt" "vmd" "nvme" "usb_storage" "usbhid" "sd_mod" "sdhci_pci" ];
12 boot.initrd.kernelModules = [ ];
13 boot.kernelModules = [ "kvm-intel" ];
14 boot.extraModulePackages = [ ];
15
16 fileSystems."/" =
17 { device = "/dev/disk/by-uuid/59c9ddc2-b914-414b-9e7e-74b405cbf3f6";
18 fsType = "ext4";
19 };
20
21 fileSystems."/boot" =
22 { device = "/dev/disk/by-uuid/7004-C5AE";
23 fsType = "vfat";
24 };
25
26 swapDevices = [ ];
27
28 # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
29 # (the default) this is the recommended approach. When using systemd-networkd it's
30 # still possible to use this option, but it's recommended to use it in conjunction
31 # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
32 networking.useDHCP = lib.mkDefault true;
33 # networking.interfaces.wlo1.useDHCP = lib.mkDefault true;
34
35 nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
36 powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
37 hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
38 # high-resolution display
39 hardware.video.hidpi.enable = lib.mkDefault true;
40}