diff options
Diffstat (limited to 'mail.nix')
-rw-r--r-- | mail.nix | 49 |
1 files changed, 49 insertions, 0 deletions
diff --git a/mail.nix b/mail.nix new file mode 100644 index 0000000..b62e51a --- /dev/null +++ b/mail.nix | |||
@@ -0,0 +1,49 @@ | |||
1 | { config | ||
2 | , lib | ||
3 | , pkgs | ||
4 | , ... | ||
5 | }: | ||
6 | |||
7 | { | ||
8 | accounts.email.maildirBasePath = "mail"; | ||
9 | accounts.email.accounts."[email protected]" = { | ||
10 | address = "[email protected]"; | ||
11 | folders = { | ||
12 | drafts = "drafts"; | ||
13 | sent = "sent"; | ||
14 | trash = "trash"; | ||
15 | inbox = "inbox"; | ||
16 | }; | ||
17 | imap = { | ||
18 | host = "mail.postale.io"; | ||
19 | port = 993; | ||
20 | }; | ||
21 | maildir = { | ||
22 | path = "personal"; | ||
23 | }; | ||
24 | mbsync = { | ||
25 | enable = true; | ||
26 | create = "maildir"; | ||
27 | expunge = "maildir"; | ||
28 | }; | ||
29 | primary = true; | ||
30 | passwordCommand = "${pkgs.gnupg}/bin/gpg -q --for-your-eyes-only --no-tty -d /home/np/.password-store/email/personal.gpg"; | ||
31 | realName = "Akshay"; | ||
32 | signature = { | ||
33 | text = '' | ||
34 | -- | ||
35 | Akshay | ||
36 | <[email protected]> | ||
37 | ''; | ||
38 | }; | ||
39 | smtp = { | ||
40 | host = "mail.postale.io"; | ||
41 | port = 587; | ||
42 | tls.useStartTls = true; | ||
43 | }; | ||
44 | userName = "[email protected]"; | ||
45 | notmuch.enable = true; | ||
46 | msmtp.enable = true; | ||
47 | |||
48 | }; | ||
49 | } | ||