aboutsummaryrefslogtreecommitdiff
path: root/programs/bash.nix
diff options
context:
space:
mode:
Diffstat (limited to 'programs/bash.nix')
-rw-r--r--programs/bash.nix5
1 files changed, 1 insertions, 4 deletions
diff --git a/programs/bash.nix b/programs/bash.nix
index 2a3cb97..bff2eb9 100644
--- a/programs/bash.nix
+++ b/programs/bash.nix
@@ -14,6 +14,7 @@
14 14
15 shellAliases = { 15 shellAliases = {
16 "..." = "cd -- ../.."; 16 "..." = "cd -- ../..";
17 "...." = "cd -- ../../..";
17 grep = "grep --color=auto"; 18 grep = "grep --color=auto";
18 l = "ls -CF"; 19 l = "ls -CF";
19 la = "ls -A"; 20 la = "ls -A";
@@ -24,7 +25,6 @@
24 tmux = "tmux -u"; 25 tmux = "tmux -u";
25 tree = "tree -C"; 26 tree = "tree -C";
26 tb = "nc termbin.com 9999"; 27 tb = "nc termbin.com 9999";
27 n = "j";
28 28
29 # git aliases 29 # git aliases
30 gb = "git branch -v"; 30 gb = "git branch -v";
@@ -71,8 +71,6 @@
71 }; 71 };
72 72
73 initExtra = '' 73 initExtra = ''
74 [ -f $HOME/.github ] && . $HOME/.github
75 eval "$(direnv hook bash)"
76 export PATH=$PATH:"$HOME/scripts" 74 export PATH=$PATH:"$HOME/scripts"
77 export PROMPT_COMMAND="tmux refresh-client -S"; 75 export PROMPT_COMMAND="tmux refresh-client -S";
78 export PS1="\n\001\e[0;36m\002λ\001\e[0m\002 "; 76 export PS1="\n\001\e[0;36m\002λ\001\e[0m\002 ";
@@ -116,7 +114,6 @@
116 function __rm() { 114 function __rm() {
117 git worktree remove "$1" 115 git worktree remove "$1"
118 } 116 }
119
120 ''; 117 '';
121 118
122 }; 119 };