aboutsummaryrefslogtreecommitdiff
path: root/programs/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'programs/git.nix')
-rw-r--r--programs/git.nix13
1 files changed, 7 insertions, 6 deletions
diff --git a/programs/git.nix b/programs/git.nix
index 69dd409..d4fac67 100644
--- a/programs/git.nix
+++ b/programs/git.nix
@@ -19,7 +19,13 @@ with theme;
19 syntax-theme = "none"; 19 syntax-theme = "none";
20 zero-style = "8"; 20 zero-style = "8";
21 navigate = "true"; 21 navigate = "true";
22 line-numbers = "true";
22 keep-plus-minus-markers = "true"; 23 keep-plus-minus-markers = "true";
24 line-numbers-zero-style = "8";
25 line-numbers-left-style = "8";
26 line-numbers-right-style = "8";
27 line-numbers-minus-style = "${base08}";
28 line-numbers-plus-style = "${base0B}";
23 decorations = { 29 decorations = {
24 file-decoration-style = "none"; 30 file-decoration-style = "none";
25 whitespace-error-style = "22 reverse"; 31 whitespace-error-style = "22 reverse";
@@ -27,7 +33,7 @@ with theme;
27 minus-emph-style = "${base08} bold"; 33 minus-emph-style = "${base08} bold";
28 plus-style = "${base0B}"; 34 plus-style = "${base0B}";
29 plus-emph-style = "${base0B} bold"; 35 plus-emph-style = "${base0B} bold";
30 file-style = "7 italic"; 36 file-style = "7 bold";
31 hunk-header-style = "7"; 37 hunk-header-style = "7";
32 hunk-header-decoration-style = "8 ul"; 38 hunk-header-decoration-style = "8 ul";
33 }; 39 };
@@ -39,11 +45,6 @@ with theme;
39 }; 45 };
40 }; 46 };
41 }; 47 };
42 # difftastic = {
43 # enable = true;
44 # background = "dark";
45 # display = "inline";
46 # };
47 aliases = { 48 aliases = {
48 co = "checkout"; 49 co = "checkout";
49 rb = "rebase"; 50 rb = "rebase";