aboutsummaryrefslogtreecommitdiff
path: root/programs/tmux.nix
diff options
context:
space:
mode:
Diffstat (limited to 'programs/tmux.nix')
-rw-r--r--programs/tmux.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/programs/tmux.nix b/programs/tmux.nix
index 15f9a13..c748a60 100644
--- a/programs/tmux.nix
+++ b/programs/tmux.nix
@@ -82,10 +82,7 @@ in
82 setw -g pane-base-index 1 82 setw -g pane-base-index 1
83 83
84 # session jumper 84 # session jumper
85 bind C-j display-popup -E "\ 85 bind-key -n C-j run-shell "tmux-fzf"
86 tmux list-sessions -F '#{session_name}' |\
87 fzf |\
88 xargs tmux switch-client -t"
89 86
90 87
91 # pane binds 88 # pane binds
@@ -101,7 +98,9 @@ in
101 98
102 # window binds 99 # window binds
103 bind -n M-h previous-window 100 bind -n M-h previous-window
104 bind -n M-i next-window 101 bind -n M-i next-window
102 bind -n M-? switch-client -p
103 bind -n M-/ switch-client -n
105 bind-key "{" split-window -h -c "#{pane_current_path}" 104 bind-key "{" split-window -h -c "#{pane_current_path}"
106 bind-key "}" split-window -v -c "#{pane_current_path}" 105 bind-key "}" split-window -v -c "#{pane_current_path}"
107 bind-key s choose-session 106 bind-key s choose-session