aboutsummaryrefslogtreecommitdiff
path: root/programs/tmux.nix
diff options
context:
space:
mode:
Diffstat (limited to 'programs/tmux.nix')
-rw-r--r--programs/tmux.nix10
1 files changed, 4 insertions, 6 deletions
diff --git a/programs/tmux.nix b/programs/tmux.nix
index 2e73f3e..b66f79e 100644
--- a/programs/tmux.nix
+++ b/programs/tmux.nix
@@ -59,18 +59,14 @@ in
59{ 59{
60 programs.tmux = { 60 programs.tmux = {
61 enable = true; 61 enable = true;
62 plugins = [ thumbs resurrect ]; 62 plugins = [ thumbs ];
63 prefix = "C-t"; 63 prefix = "C-t";
64 keyMode = "vi"; 64 keyMode = "vi";
65 terminal = "xterm-256color-italic"; 65 terminal = "xterm-256color-italic";
66 extraConfig = '' 66 extraConfig = ''
67 unbind-key C-b
68 bind-key C-t send-prefix
69
70 bind r source-file ~/.config/tmux/tmux.conf 67 bind r source-file ~/.config/tmux/tmux.conf
71 68
72 set escape-time 20 69 set escape-time 20
73
74 set -g mouse on 70 set -g mouse on
75 71
76 set -g base-index 1 72 set -g base-index 1
@@ -79,7 +75,6 @@ in
79 # session jumper 75 # session jumper
80 bind-key -n C-j run-shell "tmux-fzf" 76 bind-key -n C-j run-shell "tmux-fzf"
81 77
82
83 # pane binds 78 # pane binds
84 unbind-key E 79 unbind-key E
85 bind-key h select-pane -L 80 bind-key h select-pane -L
@@ -148,6 +143,9 @@ in
148 143
149 # popup styles 144 # popup styles
150 set -g popup-border-style "fg=colour8" 145 set -g popup-border-style "fg=colour8"
146
147 # load all sessions
148 source-file ~/.config/tmux/sessions/all
151 ''; 149 '';
152 }; 150 };
153} 151}