diff options
Diffstat (limited to 'programs/tmux.nix')
-rw-r--r-- | programs/tmux.nix | 11 |
1 files changed, 7 insertions, 4 deletions
diff --git a/programs/tmux.nix b/programs/tmux.nix index c8745c7..bfda915 100644 --- a/programs/tmux.nix +++ b/programs/tmux.nix | |||
@@ -28,12 +28,15 @@ let | |||
28 | date-bst = date-tz "Europe/London"; | 28 | date-bst = date-tz "Europe/London"; |
29 | date-hel = date-tz "Europe/Helsinki"; | 29 | date-hel = date-tz "Europe/Helsinki"; |
30 | 30 | ||
31 | copy = "${pkgs.wl-clipboard-rs}/bin/wl-copy"; | ||
32 | paste = "${pkgs.wl-clipboard-rs}/bin/wl-paste"; | ||
33 | |||
31 | # plugins | 34 | # plugins |
32 | thumbs = { | 35 | thumbs = { |
33 | plugin = pkgs.tmuxPlugins.tmux-thumbs; | 36 | plugin = pkgs.tmuxPlugins.tmux-thumbs; |
34 | extraConfig = '' | 37 | extraConfig = '' |
35 | set -g @thumbs-key F | 38 | set -g @thumbs-key F |
36 | set -g @thumbs-command 'echo -n {} | xclip -i -sel p -f | xclip -i -sel c' | 39 | set -g @thumbs-command 'echo -n {} | ${copy}' |
37 | set -g @thumbs-fg-color white | 40 | set -g @thumbs-fg-color white |
38 | set -g @thumbs-hint-bg-color yellow | 41 | set -g @thumbs-hint-bg-color yellow |
39 | set -g @thumbs-hint-fg-color black | 42 | set -g @thumbs-hint-fg-color black |
@@ -65,7 +68,7 @@ in | |||
65 | plugins = [ thumbs ]; | 68 | plugins = [ thumbs ]; |
66 | prefix = "C-t"; | 69 | prefix = "C-t"; |
67 | keyMode = "vi"; | 70 | keyMode = "vi"; |
68 | terminal = "xterm-256color-italic"; | 71 | terminal = "alacritty"; |
69 | extraConfig = '' | 72 | extraConfig = '' |
70 | bind r source-file ~/.config/tmux/tmux.conf | 73 | bind r source-file ~/.config/tmux/tmux.conf |
71 | 74 | ||
@@ -112,9 +115,9 @@ in | |||
112 | bind-key -r ">" swap-window -d -t +1 | 115 | bind-key -r ">" swap-window -d -t +1 |
113 | 116 | ||
114 | bind-key -T copy-mode-vi v send-keys -X begin-selection | 117 | bind-key -T copy-mode-vi v send-keys -X begin-selection |
115 | bind-key -T copy-mode-vi y send-keys -X copy-pipe "xclip -i -sel p -f | xclip -i -sel c " | 118 | bind-key -T copy-mode-vi y send-keys -X copy-pipe "${copy}" |
116 | bind-key -T copy-mode-vi r send-keys -X rectangle-toggle | 119 | bind-key -T copy-mode-vi r send-keys -X rectangle-toggle |
117 | bind-key -T copy-mode-vi MouseDragEnd1Pane send-keys -X copy-pipe-no-clear "xclip -i -sel p -f | xclip -i -sel c " | 120 | bind-key -T copy-mode-vi MouseDragEnd1Pane send-keys -X copy-pipe-no-clear "${copy}" |
118 | bind P paste-buffer | 121 | bind P paste-buffer |
119 | 122 | ||
120 | set-window-option -g allow-rename off | 123 | set-window-option -g allow-rename off |