aboutsummaryrefslogtreecommitdiff
path: root/scripts/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/default.nix')
-rw-r--r--scripts/default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/scripts/default.nix b/scripts/default.nix
index 627b121..b4ee23a 100644
--- a/scripts/default.nix
+++ b/scripts/default.nix
@@ -55,13 +55,13 @@ let
55 landscape-transform = builtins.toString [ 0 0 0 0 0 0 0 0 0 ]; 55 landscape-transform = builtins.toString [ 0 0 0 0 0 0 0 0 0 ];
56 portrait = pkgs.writeScriptBin "portrait" '' 56 portrait = pkgs.writeScriptBin "portrait" ''
57 ${pkgs.xorg.xrandr}/bin/xrandr -o left 57 ${pkgs.xorg.xrandr}/bin/xrandr -o left
58 ${pkgs.xorg.xinput}/bin/xinput set-prop ${touchscreen} --type=float "Coordinate Transformation Matrix" ${portait-transform} 58 ${pkgs.xorg.xinput}/bin/xinput set-prop "${touchscreen}" --type=float "Coordinate Transformation Matrix" ${portait-transform}
59 ${pkgs.xorg.xinput}/bin/xinput set-prop ${stylus} --type=float "Coordinate Transformation Matrix" ${portait-transform} 59 ${pkgs.xorg.xinput}/bin/xinput set-prop "${stylus}" --type=float "Coordinate Transformation Matrix" ${portait-transform}
60 ''; 60 '';
61 landscape = pkgs.writeScriptBin "landscape" '' 61 landscape = pkgs.writeScriptBin "landscape" ''
62 ${pkgs.xorg.xrandr}/bin/xrandr -o normal 62 ${pkgs.xorg.xrandr}/bin/xrandr -o normal
63 ${pkgs.xorg.xinput}/bin/xinput set-prop ${touchscreen} --type=float "Coordinate Transformation Matrix" ${landscape-transform} 63 ${pkgs.xorg.xinput}/bin/xinput set-prop "${touchscreen}" --type=float "Coordinate Transformation Matrix" ${landscape-transform}
64 ${pkgs.xorg.xinput}/bin/xinput set-prop ${stylus} --type=float "Coordinate Transformation Matrix" ${landscape-transform} 64 ${pkgs.xorg.xinput}/bin/xinput set-prop "${stylus}" --type=float "Coordinate Transformation Matrix" ${landscape-transform}
65 ''; 65 '';
66 66
67in 67in