aboutsummaryrefslogtreecommitdiff
path: root/services/sxhkd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'services/sxhkd.nix')
-rw-r--r--services/sxhkd.nix13
1 files changed, 10 insertions, 3 deletions
diff --git a/services/sxhkd.nix b/services/sxhkd.nix
index d8678af..b1fc55c 100644
--- a/services/sxhkd.nix
+++ b/services/sxhkd.nix
@@ -19,11 +19,18 @@ in
19{ 19{
20 services.sxhkd = { 20 services.sxhkd = {
21 enable = true; 21 enable = true;
22 keybindings = { 22 keybindings =
23 let
24 vol_up ="${volume}/bin/volume sset Master 2%+";
25 vol_down ="${volume}/bin/volume sset Master 2%-";
26 in
27 {
23 "super + slash" = "${pkgs.light}/bin/light -A 2"; 28 "super + slash" = "${pkgs.light}/bin/light -A 2";
24 "super + shift + slash" = "${pkgs.light}/bin/light -U 2"; 29 "super + shift + slash" = "${pkgs.light}/bin/light -U 2";
25 "super + semicolon" = "${volume}/bin/volume sset Master 2%+"; 30 "super + semicolon" = vol_up;
26 "super + shift + semicolon" = "${volume}/bin/volume sset Master 2%-"; 31 "super + shift + semicolon" = vol_down;
32 "XF86AudioRaiseVolume" = vol_up;
33 "XF86AudioLowerVolume" = vol_down;
27 "super + ctrl + space" = "${pkgs.dunst}/bin/dunstctl close"; 34 "super + ctrl + space" = "${pkgs.dunst}/bin/dunstctl close";
28 "super + shift + space" = "${pkgs.dunst}/bin/dunstctl history-pop"; 35 "super + shift + space" = "${pkgs.dunst}/bin/dunstctl history-pop";
29 "super + ctrl + shift + space" = "${pkgs.dunst}/bin/dunstctl close-all"; 36 "super + ctrl + shift + space" = "${pkgs.dunst}/bin/dunstctl close-all";