aboutsummaryrefslogtreecommitdiff
path: root/services/sxhkd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'services/sxhkd.nix')
-rw-r--r--services/sxhkd.nix16
1 files changed, 3 insertions, 13 deletions
diff --git a/services/sxhkd.nix b/services/sxhkd.nix
index fe54cbf..19d6917 100644
--- a/services/sxhkd.nix
+++ b/services/sxhkd.nix
@@ -4,27 +4,17 @@
4, ... 4, ...
5}: 5}:
6 6
7let
8 jumpTo = app: "${pkgs.xdotool}/bin/xdotool search \"${app}\" windowactivate";
9in
10{ 7{
11 services.sxhkd = { 8 services.sxhkd = {
12 enable = true; 9 enable = true;
13 keybindings = { 10 keybindings = {
14 "super + slash" = "${pkgs.light}/bin/light -A 5"; 11 "super + slash" = "${pkgs.light}/bin/light -A 5";
15 "super + shift + slash" = "${pkgs.light}/bin/light -U 5"; 12 "super + shift + slash" = "${pkgs.light}/bin/light -U 5";
16
17 "super + semicolon" = "${pkgs.alsaUtils}/bin/amixer sset Master 2%+"; 13 "super + semicolon" = "${pkgs.alsaUtils}/bin/amixer sset Master 2%+";
18 "super + shift + semicolon" = "${pkgs.alsaUtils}/bin/amixer sset Master 2%-"; 14 "super + shift + semicolon" = "${pkgs.alsaUtils}/bin/amixer sset Master 2%-";
19 15 "super + space" = "${pkgs.dunst}/bin/dunstctl close";
20 # jump to firefox 16 "super + ctrl + space" = "${pkgs.dunst}/bin/dunstctl close-all";
21 "super + alt + shift + ctrl + f" = jumpTo "Mozilla Firefox"; 17 "super + shift + space" = "${pkgs.dunst}/bin/dunstctl history-pop";
22
23 # jump to st
24 "super + alt + shift + ctrl + s" = jumpTo "st";
25
26 # jump to zathura
27 "super + alt + shift + ctrl + z" = jumpTo "zathura";
28 }; 18 };
29 }; 19 };
30} 20}