aboutsummaryrefslogtreecommitdiff
path: root/services/sxhkd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'services/sxhkd.nix')
-rw-r--r--services/sxhkd.nix9
1 files changed, 2 insertions, 7 deletions
diff --git a/services/sxhkd.nix b/services/sxhkd.nix
index 3bb3da8..d8678af 100644
--- a/services/sxhkd.nix
+++ b/services/sxhkd.nix
@@ -9,11 +9,6 @@ let
9 '' 9 ''
10 ${pkgs.libnotify}/bin/notify-send ${text} -h int:value:${value} -h string:synchronous:volume -h string:hlcolor:"${theme.base0C}" 10 ${pkgs.libnotify}/bin/notify-send ${text} -h int:value:${value} -h string:synchronous:volume -h string:hlcolor:"${theme.base0C}"
11 ''; 11 '';
12 brightness = pkgs.writeScriptBin "brightness" ''
13 ${pkgs.light}/bin/light $@
14 v=$(${pkgs.light}/bin/light -G)
15 ${progress "brightness" "$v"}
16 '';
17 volume = pkgs.writeScriptBin "volume" '' 12 volume = pkgs.writeScriptBin "volume" ''
18 ${pkgs.alsaUtils}/bin/amixer $@ 13 ${pkgs.alsaUtils}/bin/amixer $@
19 v=$(${pkgs.alsaUtils}/bin/amixer sget Master | ${pkgs.gawk}/bin/awk -F"[][%]" '/Left:/ {print $2}') 14 v=$(${pkgs.alsaUtils}/bin/amixer sget Master | ${pkgs.gawk}/bin/awk -F"[][%]" '/Left:/ {print $2}')
@@ -25,8 +20,8 @@ in
25 services.sxhkd = { 20 services.sxhkd = {
26 enable = true; 21 enable = true;
27 keybindings = { 22 keybindings = {
28 "super + slash" = "${brightness}/bin/brightness -A 2"; 23 "super + slash" = "${pkgs.light}/bin/light -A 2";
29 "super + shift + slash" = "${brightness}/bin/brightness -U 2"; 24 "super + shift + slash" = "${pkgs.light}/bin/light -U 2";
30 "super + semicolon" = "${volume}/bin/volume sset Master 2%+"; 25 "super + semicolon" = "${volume}/bin/volume sset Master 2%+";
31 "super + shift + semicolon" = "${volume}/bin/volume sset Master 2%-"; 26 "super + shift + semicolon" = "${volume}/bin/volume sset Master 2%-";
32 "super + ctrl + space" = "${pkgs.dunst}/bin/dunstctl close"; 27 "super + ctrl + space" = "${pkgs.dunst}/bin/dunstctl close";