aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/default.nix b/default.nix
index 78e9f1f..a56a5ea 100644
--- a/default.nix
+++ b/default.nix
@@ -1,12 +1,16 @@
1{ mkDerivation, base, containers, parsec, stdenv }: 1{ mkDerivation, base, containers, monad-memo, parsec, split, stdenv
2, strings
3}:
2mkDerivation { 4mkDerivation {
3 pname = "aoc"; 5 pname = "aoc";
4 version = "0.1.0.0"; 6 version = "0.1.0.0";
5 src = ./.; 7 src = ./.;
6 isLibrary = true; 8 isLibrary = true;
7 isExecutable = true; 9 isExecutable = true;
8 libraryHaskellDepends = [ base ]; 10 libraryHaskellDepends = [ base containers ];
9 executableHaskellDepends = [ base containers parsec ]; 11 executableHaskellDepends = [
12 base containers monad-memo parsec split strings
13 ];
10 license = "unknown"; 14 license = "unknown";
11 hydraPlatforms = stdenv.lib.platforms.none; 15 hydraPlatforms = stdenv.lib.platforms.none;
12} 16}