summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAkshay <[email protected]>2021-08-08 05:46:39 +0100
committerAkshay <[email protected]>2021-08-08 05:46:39 +0100
commit8d568855b305580591263114cc356726f393e4bf (patch)
tree0e8916bfd0f1a88201b5a2a5c39d0faef1465d5c /flake.nix
init
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..4c483e6
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,27 @@
1{
2 inputs = {
3 utils.url = "github:numtide/flake-utils";
4 };
5
6 outputs = { self, nixpkgs, utils, ... }:
7 utils.lib.eachDefaultSystem (system:
8 let
9 pname = "grump";
10 version = "0.0.0";
11 pkgs = nixpkgs.legacyPackages."${system}";
12
13 buildInputs = with pkgs.ocamlPackages; [
14 utop
15 pkgs.nixUnstable
16 ];
17
18 in
19 with pkgs;
20 rec {
21 defaultPackage = ocamlPackages.buildDunePackage rec {
22 inherit pname version buildInputs;
23 useDune2 = true;
24 src = ./.;
25 };
26 });
27}