aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d343a43..3234a7f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,9 +3,24 @@ name = "obi"
3version = "0.1.0" 3version = "0.1.0"
4authors = ["Akshay <[email protected]>"] 4authors = ["Akshay <[email protected]>"]
5edition = "2018" 5edition = "2018"
6description = "the 1-bit image format"
7homepage = "https://github.com/nerdypepper/obi"
8repository = "https://github.com/nerdypepper/obi"
9readme = './readme.md'
10license = "MIT"
6 11
7# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html 12# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
8 13
9[dependencies] 14[dependencies]
10byteorder = "1.4.2" 15byteorder = "1.4.2"
11bitvec = "0.21.0" 16bitvec = "0.21.0"
17sdl2 = {version = "0.34", optional = true}
18
19[features]
20default = []
21viewer = ["sdl2"]
22
23[[bin]]
24name = "obiv"
25path = "src/bin/viewer.rs"
26required-features = ["viewer"]