diff options
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 15 |
1 files changed, 15 insertions, 0 deletions
@@ -3,9 +3,24 @@ name = "obi" | |||
3 | version = "0.1.0" | 3 | version = "0.1.0" |
4 | authors = ["Akshay <[email protected]>"] | 4 | authors = ["Akshay <[email protected]>"] |
5 | edition = "2018" | 5 | edition = "2018" |
6 | description = "the 1-bit image format" | ||
7 | homepage = "https://github.com/nerdypepper/obi" | ||
8 | repository = "https://github.com/nerdypepper/obi" | ||
9 | readme = './readme.md' | ||
10 | license = "MIT" | ||
6 | 11 | ||
7 | # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html | 12 | # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html |
8 | 13 | ||
9 | [dependencies] | 14 | [dependencies] |
10 | byteorder = "1.4.2" | 15 | byteorder = "1.4.2" |
11 | bitvec = "0.21.0" | 16 | bitvec = "0.21.0" |
17 | sdl2 = {version = "0.34", optional = true} | ||
18 | |||
19 | [features] | ||
20 | default = [] | ||
21 | viewer = ["sdl2"] | ||
22 | |||
23 | [[bin]] | ||
24 | name = "obiv" | ||
25 | path = "src/bin/viewer.rs" | ||
26 | required-features = ["viewer"] | ||