aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorAkshay <[email protected]>2021-04-10 13:08:33 +0100
committerAkshay <[email protected]>2021-04-10 13:08:33 +0100
commiteab6c543d19f7546f1151cca32663035006af702 (patch)
tree4a26dc55da9739a26a63ff3e55172df4cfbe0754 /shell.nix
parent9dc282a130312333e96a9d2edfa1fd5cd351fd3f (diff)
add backwards compat to legacy nix commands
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..9eb132a
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,13 @@
1(import
2 (
3 let
4 lock = builtins.fromJSON (builtins.readFile ./flake.lock);
5 in
6 fetchTarball {
7 url = "https://github.com/edolstra/flake-compat/archive/${lock.nodes.flake-compat.locked.rev}.tar.gz";
8 sha256 = lock.nodes.flake-compat.locked.narHash;
9 }
10 )
11 {
12 src = ./.;
13 }).shellNix