aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorAkshay <[email protected]>2020-10-15 10:35:40 +0100
committerAkshay <[email protected]>2020-10-15 10:35:40 +0100
commit9a5f28025aa5ed89be763dd874590c5ae3cb45b5 (patch)
treeaf9d13ea140cd75b89410d8409cbce1afc7f431b /shell.nix
parentc9958740743bd38f600d6b3d2f47af474def714f (diff)
pin nixpkgs to 20.03, fix broken readline dep
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix27
1 files changed, 14 insertions, 13 deletions
diff --git a/shell.nix b/shell.nix
index b1a597f..15334f5 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,19 +1,21 @@
1let 1let
2 sources = import ./nix/sources.nix;
3 pkgs = import sources.nixpkgs {};
2 4
3 all-hies = fetchTarball { 5 inherit (pkgs) haskellPackages;
4 url = "https://github.com/infinisil/all-hies/tarball/534ac517b386821b787d1edbd855b9966d0c0775"; 6 all-hls = pkgs.fetchFromGitHub {
5 sha256 = "0bw1llpwxbh1dnrnbxkj2l0j58s523hjivszf827c3az5i4py1i2"; 7 owner = "masaeedu";
8 repo = "all-hls";
9 rev = "155e57d7ca9f79ce293360f98895e9bd68d12355";
10 sha256 = "04s3mrxjdr7gmd901l1z23qglqmn8i39v7sdf2fv4zbv6hz24ydb";
6 }; 11 };
7 12
8 pkgs = import <nixpkgs> { 13 hls = import all-hls {
9 # Pass no config for purity 14 platform = "Linux";
10 config = {}; 15 version = "0.4.0";
11 overlays = [ 16 ghc = "8.6.5";
12 (import all-hies {}).overlay 17 }; # All parameters are optional. The default values are shown here.
13 ];
14 };
15 18
16 inherit (pkgs) haskellPackages;
17 19
18 haskellDeps = ps: with ps; [ 20 haskellDeps = ps: with ps; [
19 base 21 base
@@ -30,11 +32,10 @@ let
30 pkgs.gdb 32 pkgs.gdb
31 pkgs.cabal2nix 33 pkgs.cabal2nix
32 haskellPackages.cabal-install 34 haskellPackages.cabal-install
33 haskellPackages.hie
34 haskellPackages.hoogle 35 haskellPackages.hoogle
35 ]; 36 ];
36in 37in
37pkgs.stdenv.mkDerivation { 38pkgs.stdenv.mkDerivation {
38 name = "env"; 39 name = "env";
39 buildInputs = externalPackages; 40 buildInputs = externalPackages ++ [ hls ];
40} 41}