aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJonas Schievink <[email protected]>2021-05-30 22:46:39 +0100
committerJonas Schievink <[email protected]>2021-05-30 22:46:39 +0100
commitb12d8dcb828df8403b8f486f279f0eda3303a890 (patch)
treeee3b4453a445aac21e02c7f621cd3b355319c54b /Cargo.toml
parent06b301e2f8a9f8607dfe3f0132dce68deae74ad5 (diff)
Don't force-disable incremental
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 0 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 498cf7d62..e237b13dc 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,10 +3,6 @@ resolver = "2"
3members = ["xtask/", "lib/*", "crates/*"] 3members = ["xtask/", "lib/*", "crates/*"]
4 4
5[profile.dev] 5[profile.dev]
6# We do want incremental builds, but they are broken at the moment :(
7# https://github.com/rust-lang/rust/issues/85003#issuecomment-833796289
8incremental = false
9
10# Disabling debug info speeds up builds a bunch, 6# Disabling debug info speeds up builds a bunch,
11# and we don't rely on it for debugging that much. 7# and we don't rely on it for debugging that much.
12debug = 0 8debug = 0
@@ -21,9 +17,6 @@ text-size.opt-level = 3
21miniz_oxide.opt-level = 3 17miniz_oxide.opt-level = 3
22 18
23[profile.release] 19[profile.release]
24# We do want incremental release builds, but they are broken at the moment :(
25# https://github.com/rust-lang/rust/issues/85003#issuecomment-833796289
26incremental = false
27debug = 0 # Set this to 1 or 2 to get more useful backtraces in debugger. 20debug = 0 # Set this to 1 or 2 to get more useful backtraces in debugger.
28 21
29[profile.test] 22[profile.test]