aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAleksey Kladov <[email protected]>2020-08-18 16:44:51 +0100
committerAleksey Kladov <[email protected]>2020-08-18 16:44:51 +0100
commitbbb1c617b9198c230d8331dc0ffc2affb01d2e7a (patch)
treefcb36a78f9a0fb9be41b66ed1dac4d4e380f8f9d /Cargo.toml
parentaad911fb0cd772e809270be3e0a526d4738b9dd5 (diff)
Speedup tests in dev mode
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml47
1 files changed, 22 insertions, 25 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 612e6809f..218581d9d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,37 +2,34 @@
2members = [ "crates/*", "xtask/" ] 2members = [ "crates/*", "xtask/" ]
3 3
4[profile.dev] 4[profile.dev]
5# disabling debug info speeds up builds a bunch, 5# Disabling debug info speeds up builds a bunch,
6# and we don't rely on it for debugging that much. 6# and we don't rely on it for debugging that much.
7debug = 0 7debug = 0
8 8
9[profile.dev.package]
10# These speed up local tests.
11rowan.opt-level = 3
12rustc-hash.opt-level = 3
13smol_str.opt-level = 3
14text-size.opt-level = 3
15# This speeds up `cargo xtask dist`.
16miniz_oxide.opt-level = 3
17
9[profile.release] 18[profile.release]
10incremental = true 19incremental = true
11debug = 0 # set this to 1 or 2 to get more useful backtraces in debugger 20debug = 0 # Set this to 1 or 2 to get more useful backtraces in debugger.
12
13# ideally, we would use `build-override` here, but some crates are also
14# needed at run-time and we end up compiling them twice
15[profile.release.package.proc-macro2]
16opt-level = 0
17[profile.release.package.quote]
18opt-level = 0
19[profile.release.package.syn]
20opt-level = 0
21[profile.release.package.serde_derive]
22opt-level = 0
23[profile.release.package.chalk-derive]
24opt-level = 0
25[profile.release.package.salsa-macros]
26opt-level = 0
27[profile.release.package.tracing-attributes]
28opt-level = 0
29[profile.release.package.xtask]
30opt-level = 0
31 21
32# Gzipping the artifacts is up to 10 times faster with optimizations (`cargo xtask dist`). 22# Ideally, we would use `build-override` here, but some crates are also
33# `miniz_oxide` is the direct dependency of `flate2` which does all the heavy lifting 23# needed at run-time and we end up compiling them twice.
34[profile.dev.package.miniz_oxide] 24[profile.release.package]
35opt-level = 3 25chalk-derive.opt-level = 0
26proc-macro2.opt-level = 0
27quote.opt-level = 0
28salsa-macros.opt-level = 0
29serde_derive.opt-level = 0
30syn.opt-level = 0
31tracing-attributes.opt-level = 0
32xtask.opt-level = 0
36 33
37[patch.'crates-io'] 34[patch.'crates-io']
38# rowan = { path = "../rowan" } 35# rowan = { path = "../rowan" }