aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2020-02-15 22:35:44 +0000
committerGitHub <[email protected]>2020-02-15 22:35:44 +0000
commitd9767727168c68b4ecf930c9dab5a950c0be8e7b (patch)
tree7b4efbd8218d5323bc869de7d8e665a94f6178ce /Cargo.toml
parentff7110f761d21f8323560ce177a5518591af79a0 (diff)
parent3484d727c3b26e9596ec3bd671e2a76a87cdb5fd (diff)
Merge #3157
3157: Extend analysis-stats a bit r=matklad a=flodiebold This adds some tools helpful when debugging nondeterminism in analysis-stats: - a `--randomize` option that analyses everything in random order - a `-vv` option that prints even more detail Also add a debug log if Chalk fuel is exhausted (which would be a source of nondeterminism, but didn't happen in my tests). I found one source of nondeterminism (rust-lang/chalk#331), but there are still other cases remaining. Co-authored-by: Florian Diebold <[email protected]>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e5620b1b7..c034e2424 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -31,3 +31,8 @@ opt-level = 0
31 31
32[patch.'crates-io'] 32[patch.'crates-io']
33# rowan = { path = "../rowan" } 33# rowan = { path = "../rowan" }
34
35[patch.'https://github.com/rust-lang/chalk.git']
36# chalk-solve = { path = "../chalk/chalk-solve" }
37# chalk-rust-ir = { path = "../chalk/chalk-rust-ir" }
38# chalk-ir = { path = "../chalk/chalk-ir" }