aboutsummaryrefslogtreecommitdiff
path: root/crates/call_info/Cargo.toml
diff options
context:
space:
mode:
authorIgor Aleksanov <[email protected]>2020-10-18 11:09:00 +0100
committerIgor Aleksanov <[email protected]>2020-10-18 11:09:00 +0100
commit9e7c952bbddc2e6763c49f0511a295362e9893d6 (patch)
tree5b144eabe1eaf62aa1ec5b804ee6fff00f5f84e9 /crates/call_info/Cargo.toml
parent2067a410f31810f6e1941a86cdea0247c3b7d6f4 (diff)
Extract call_info and completion into separate crates
Diffstat (limited to 'crates/call_info/Cargo.toml')
-rw-r--r--crates/call_info/Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/crates/call_info/Cargo.toml b/crates/call_info/Cargo.toml
new file mode 100644
index 000000000..98c0bd6db
--- /dev/null
+++ b/crates/call_info/Cargo.toml
@@ -0,0 +1,26 @@
1[package]
2name = "call_info"
3version = "0.0.0"
4description = "TBD"
5license = "MIT OR Apache-2.0"
6authors = ["rust-analyzer developers"]
7edition = "2018"
8
9[lib]
10doctest = false
11
12[dependencies]
13either = "1.5.3"
14
15stdx = { path = "../stdx", version = "0.0.0" }
16syntax = { path = "../syntax", version = "0.0.0" }
17base_db = { path = "../base_db", version = "0.0.0" }
18ide_db = { path = "../ide_db", version = "0.0.0" }
19test_utils = { path = "../test_utils", version = "0.0.0" }
20
21# call_info crate should depend only on the top-level `hir` package. if you need
22# something from some `hir_xxx` subpackage, reexport the API via `hir`.
23hir = { path = "../hir", version = "0.0.0" }
24
25[dev-dependencies]
26expect-test = "1.0"