aboutsummaryrefslogtreecommitdiff
path: root/crates/gen_lsp_server/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <bors[bot]@users.noreply.github.com>2019-05-23 10:23:36 +0100
committerbors[bot] <bors[bot]@users.noreply.github.com>2019-05-23 10:23:36 +0100
commit078c0e26c3ff4d9652bcb4845b5f4665c2e0989d (patch)
tree24719bb7205e95c1b2130238c6927dbfaa8db3e5 /crates/gen_lsp_server/Cargo.toml
parenta25e103e4542637047fe388a926aebddca07b3b7 (diff)
parentcbd131acbe497795028844a592a438b70a30ba32 (diff)
Merge #1313
1313: Update `gen_lsp_server` examples r=matklad a=dmoonfire - updated the documentation with an example that has no errors with current compiler - added two example code to test compilation and show in use - one example is the bare bones version in documentation - the other example is the same but with logging statements to show flow Co-authored-by: Dylan Moonfire <[email protected]>
Diffstat (limited to 'crates/gen_lsp_server/Cargo.toml')
-rw-r--r--crates/gen_lsp_server/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/crates/gen_lsp_server/Cargo.toml b/crates/gen_lsp_server/Cargo.toml
index ba8bfdbd3..fa2fefea5 100644
--- a/crates/gen_lsp_server/Cargo.toml
+++ b/crates/gen_lsp_server/Cargo.toml
@@ -14,3 +14,6 @@ failure = "0.1.4"
14serde_json = "1.0.34" 14serde_json = "1.0.34"
15serde = { version = "1.0.83", features = ["derive"] } 15serde = { version = "1.0.83", features = ["derive"] }
16crossbeam-channel = "0.3.5" 16crossbeam-channel = "0.3.5"
17
18[dev-dependencies]
19flexi_logger = "0.11.0"