aboutsummaryrefslogtreecommitdiff
path: root/crates/hir/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2020-08-25 10:11:26 +0100
committerGitHub <[email protected]>2020-08-25 10:11:26 +0100
commit96cbad9fb5a67dd6cd83fe217716d932300122b5 (patch)
treeb62378abb477d2cdfedf462c1b25b6d9fecc9f75 /crates/hir/Cargo.toml
parentb4bc34649857cfcf7fcb39b9af02342fb7b8c89e (diff)
parentb835f06cecd2189cb32a431fdb85245fbf53032a (diff)
Merge #4873
4873: Resolve links in hover documentation r=matklad a=zacps This PR resolves links in hover documentation. Both the upcoming intra-doc-links style and the old "path-based" style. ## Todo * [x] More tests * [ ] Benchmark (Is there an easy way to benchmark this?) * [x] ~~Resolve issues with the markdown parser/get rid of it~~ Migrate to `pulldown_cmark_to_cmark` * [x] Reorganise code (Tips appreciated) --- Fixes #503 Co-authored-by: Zac Pullar-Strecker <[email protected]>
Diffstat (limited to 'crates/hir/Cargo.toml')
-rw-r--r--crates/hir/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/crates/hir/Cargo.toml b/crates/hir/Cargo.toml
index 60a48170e..72f941c46 100644
--- a/crates/hir/Cargo.toml
+++ b/crates/hir/Cargo.toml
@@ -15,6 +15,7 @@ rustc-hash = "1.1.0"
15either = "1.5.3" 15either = "1.5.3"
16arrayvec = "0.5.1" 16arrayvec = "0.5.1"
17itertools = "0.9.0" 17itertools = "0.9.0"
18url = "2.1.1"
18 19
19stdx = { path = "../stdx", version = "0.0.0" } 20stdx = { path = "../stdx", version = "0.0.0" }
20syntax = { path = "../syntax", version = "0.0.0" } 21syntax = { path = "../syntax", version = "0.0.0" }
@@ -23,3 +24,4 @@ profile = { path = "../profile", version = "0.0.0" }
23hir_expand = { path = "../hir_expand", version = "0.0.0" } 24hir_expand = { path = "../hir_expand", version = "0.0.0" }
24hir_def = { path = "../hir_def", version = "0.0.0" } 25hir_def = { path = "../hir_def", version = "0.0.0" }
25hir_ty = { path = "../hir_ty", version = "0.0.0" } 26hir_ty = { path = "../hir_ty", version = "0.0.0" }
27tt = { path = "../tt", version = "0.0.0" }