aboutsummaryrefslogtreecommitdiff
path: root/crates/hir_def/Cargo.toml
diff options
context:
space:
mode:
authorAleksey Kladov <[email protected]>2021-04-04 10:06:01 +0100
committerAleksey Kladov <[email protected]>2021-04-04 10:06:01 +0100
commitd1474ae51806cd5382c988fac1cf70a7f2718f4a (patch)
tree36350873c4d6721f6b20754c245d2ec61987761e /crates/hir_def/Cargo.toml
parentc9bcbf9a43eb0bf1a5255f704080305e568f0a36 (diff)
Check if bitflags deps pulls its weight
Bitflags is generally a good dependency -- it's lightweight, well maintained and embraced by the ecosystem. I wonder, however, do we really need it? Doesn't feel like it adds much to be honest.
Diffstat (limited to 'crates/hir_def/Cargo.toml')
-rw-r--r--crates/hir_def/Cargo.toml1
1 files changed, 0 insertions, 1 deletions
diff --git a/crates/hir_def/Cargo.toml b/crates/hir_def/Cargo.toml
index 60adb655c..43324d8d9 100644
--- a/crates/hir_def/Cargo.toml
+++ b/crates/hir_def/Cargo.toml
@@ -10,7 +10,6 @@ edition = "2018"
10doctest = false 10doctest = false
11 11
12[dependencies] 12[dependencies]
13bitflags = "1.2.1"
14cov-mark = { version = "1.1", features = ["thread-local"] } 13cov-mark = { version = "1.1", features = ["thread-local"] }
15dashmap = { version = "4.0.2", features = ["raw-api"] } 14dashmap = { version = "4.0.2", features = ["raw-api"] }
16log = "0.4.8" 15log = "0.4.8"