aboutsummaryrefslogtreecommitdiff
path: root/crates/hir_ty/Cargo.toml
diff options
context:
space:
mode:
authorDawer <[email protected]>2021-04-22 16:17:27 +0100
committerDawer <[email protected]>2021-05-31 20:03:45 +0100
commitc3c2893f302d087ff3c1ddd3a1d4e88c03c4356b (patch)
treedc24743a4482f625b287c697f3ef17bfbfb9097f /crates/hir_ty/Cargo.toml
parent7c1d8ca63510bb719fd91bbf38692e45b19c04d6 (diff)
Update match checking.
fn is_useful , more skeletons Specify a lifetime on pattern references impl PatStack fill impl Matrix PatStack::pop_head_constructor Index-based approach struct PatCtxt fields construction fn Fields::wildcards split wildcard fn Constructor::is_covered_by_any(..) fn Matrix::specialize_constructor(..) impl Usefulness Initial work on witness construction Reorganize files Replace match checking diagnostic Handle types of expanded patterns unit match checking go brrr
Diffstat (limited to 'crates/hir_ty/Cargo.toml')
-rw-r--r--crates/hir_ty/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/crates/hir_ty/Cargo.toml b/crates/hir_ty/Cargo.toml
index c3d02424d..4b714c6d8 100644
--- a/crates/hir_ty/Cargo.toml
+++ b/crates/hir_ty/Cargo.toml
@@ -22,6 +22,7 @@ chalk-solve = { version = "0.68", default-features = false }
22chalk-ir = "0.68" 22chalk-ir = "0.68"
23chalk-recursive = "0.68" 23chalk-recursive = "0.68"
24la-arena = { version = "0.2.0", path = "../../lib/arena" } 24la-arena = { version = "0.2.0", path = "../../lib/arena" }
25once_cell = { version = "1.5.0" }
25 26
26stdx = { path = "../stdx", version = "0.0.0" } 27stdx = { path = "../stdx", version = "0.0.0" }
27hir_def = { path = "../hir_def", version = "0.0.0" } 28hir_def = { path = "../hir_def", version = "0.0.0" }